FSX SP2 - Bogus Error Message on Setup 

Setup developer Bob Arnson offers this workaround to a common issue on his blog:

When installing FSX Service Pack 2, you might see this message: "Microsoft Flight Simulator X Service Pack 2 requires the English version of Flight Simulator X."

So far, the immediate cause is the same: missing data in the registry. During testing, the root cause was also the same: Copying the installed files from another partition or machine rather than using the installer. That's not officially supported, of course, but given the size of Flight Simulator, it's fairly common to want to move the installed files (to a bigger partition, for example) without reinstalling.

Service Pack 2 requires the registry data that the original RTM and SP1 installers write. (It uses the data in the registry to find the installation directory and the language.dll file. It checks the version information in language.dll to make sure it has the same language as the SP2 installer; otherwise, you'd end up with a broken mix of localized content.)

Unfortunately, the original RTM installer doesn't rewrite those registry values when you do a repair, so what works is to uninstall and reinstall RTM, then SP1, then SP2.

That said, here's a shortcut. Note that it involves editing the registry, which can be hazardous to your computer's health. If you don't feel comfortable doing this, uninstall and reinstall is a safe choice.

  1. Start RegEdit.
  2. On 32-bit operating systems, open the HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ microsoft games\ flight simulator\ 10.0 key in the left pane.
  3. On 64-bit operating systems, open the HKEY_LOCAL_MACHINE\ SOFTWARE\ Wow6432Node\ Microsoft\ Microsoft Games\ Flight Simulator\ 10.0 key in the left pane.
  4. Choose Edit|New|String Value.
  5. Replace New Value #1 by typing SetupPath.
  6. Double-click SetupPath and in the Value data box, type the full directory path where you installed or copied Flight Simulator X.


The SP2 installer should then be able to find language.dll and verify that it's the right language for the version of SP2 you're trying to install.

That's the only common setup problem we've seen — as of today, anyway. I'll update this blog entry with additional items if/when they come up.