Dashboard per l’analisi delle risorse umane con Excel 2010
 

 Come fare a...

 
  • lug
    05
    20
    11

    Dashboard per l’analisi delle risorse umane con Excel 2010

    System Account
    07:13 AM

    La centralità delle risorse umane: l'analisi dei numeri

    Scopo del seguente articolo è quello di applicare funzioni e strumenti Excel 2010 per costruire un dashboard statistico sull’andamento delle risorse umane all’interno di un’azienda. La gestione delle risorse umane, intese come perno centrale e patrimonio di un’azienda diventa efficace se attuata attraverso una politica di individuazione, monitoraggio e valorizzazione delle risorse umane. Sul tema delle competenze avevamo già dedicato un articolo pubblicato sul sempre portale Microsoft PMI, dal titolo “Valutare le risorse umane attraverso competenze ed obiettivi da raggiungere” .
    Oggi ci focalizzeremo su semplici analisi e statistiche del personale presente in una qualunque azienda Alfa (Trend, salari medi, assenze ecc).
    L’esempio riportato è molto semplicistico ma può essere esteso anche a popolazioni aziendali molto più estese e complesse. Sul mercato sono presenti diversi software di gestione del personale che possono fornire statistiche in pochi click, tuttavia il Responsabile RU che non ha un budget per un simile investimento, può ricorrere all’ausilio di Ms Excel , ottenere ottimi risultati e massimizzare le customizzazioni al modello.

     
    Come costruire il Dashboard delle risorse umane con Excel 2010
     
    Il nostro file è composto da tre fogli di lavoro:
     
    Database: dove sono state inserite tutte le informazioni del personale
    Tabelle: dove sono state create delle tabelle riepilogative
    Dashboard: dove è stato creato il cruscotto aziendale quale output finale grafico e numerico delle statistiche ritenute rilevanti ai fini statistici.
     
    I nomi del personale utilizzato nell’esempio, i dati e i numeri sono puramente casuali; qui di seguito si riporta uno stralcio del database con i relativi campi utilizzati:
     
    Figura 1
     
    Nel modello sono stati individuati alcuni obiettivi di analisi riepilogabili qui di seguito:
     
    1.
    Breakdown % del personale per divisione
    2.
    Numero di risorse umane per dipartimento
    3.
    Scheda di sintesi di una singola risorsa
    4.
    Trend di crescita delle risorse umane presenti in azienda (Year over Year)
    5.
    Distribuzione salariale
     
    Il modello Excel implementato per monitorare i suddetti output, non richiedono la registrazione o la programmazione di alcuna macro; si sono infatti privilegiate funzioni di Excel 2010, che hanno consentito comunque di automatizzare e raggruppare i dati necessari.
    Ad esempio per realizzare il grafico del trend del personale sì è utilizzata la funzione conta.se al fine di raggruppare il numero di risorse umane presenti in azienda per ciascun anno:
    =CONTA.SE(Database!$C$3:$C$98;"<"&A3)= 6, e così via per le righe successive.
     
    Figura 2
     
    Il raggruppamento dei dati per department è stato eseguito mediante l’utilizzo della funzione somma.se:
    =SOMMA.SE(Database!$B$3:$B$98;$A17;Database!D$3:D$98)
    Il numero di risorse umane per Dipartimento è stato ottenuto attraverso una funzione composta costituita da conta se e una funzione di concatenamento tramite la &:
    =CONTA.SE(Database!$B$3:$B$98;"="&A17)
    A questo punto il nostro dashboard con i dati statistici che ci occorrono è in pratica già pronto; grazie a Excel 2010 la grafica e le soluzioni a disposizione sono decisamente arricchite rispetto alle precedenti versioni Excel e ci si può davvero sbizzarrire.
     
    Figura 3
     
    Come potete constatare il suddetto dashboard esemplificativo è costituito da un serie di grafici:
     
    Istogramma (crescita personale – Year over Year)
    Grafico a Torta (% personale per dipartimento)
    Grafico a Barre (numero persone per dipartimento)
    Grafico ad Area (Distribuzione salariale)
     
    Come potete notare nella suddetta figura, in alto a destra, è stata poi creata un’area dinamica denominata Scheda del Dipendente: si seleziona il nome del dipendente e in automatico sono riportate le informazioni di quello specifico dipendente.
     
    Figura 4
     
    La scheda del dipendente recupera i dati attraverso la funzione composta denominata Indice Confronta:
    La funzione Indice può essere rappresentata dalla sintassi indicata qui di seguito:
    =INDICE(matrice; riga; colonna)
    La funzione Confronta cerca un dato in un range di valori e restituisce la relativa posizione (il numero della riga).
    Qui di seguito un esempio esteso della funzione utilizzata nella cella O13
    =INDICE(Database!$A$3:$I$98;CONFRONTA(Dashboard!$K$9;Database!$A$3:$A$98;0);3)
    Simili dashboard sono comodamente personalizzabili e a ogni specifica esigenza e realtà aziendale. L’importante è avere ben chiare le idee e i dati statistici da rappresentare; poi un pizzico di creatività, una linearità nella costruzione del modello e lo sfruttamento delle potenzialità di Excel 2010 ti permetteranno di costruire il tuo dashboard dinamico con estrema semplicità.

    Scarica: dashboard per l'analisi delle risorse umane.

    Autore: Luca Vanzulli
    Fonte:
    B2Corporate.com
     
     
Seguici su Twitter Trovaci su Facebook