Developer Tools

Thank you for downloading

  • Visual FoxPro 8.0 GDI+ Runtime Library Update

    If your download does not start after 30 seconds, Click here
      • This security update requires a released version of Visual FoxPro 8.0. Developers who have distributed custom Visual FoxPro 8.0 runtime applications that include a copy of the vulnerable gdiplus.dll file should evaluate the need to deploy the security update for the Microsoft Visual FoxPro 8.0 Runtime Library. This update is a downloadable setup that can be distributed by the developer to a customer who has a custom Visual FoxPro 8.0 runtime application. This security update resolves a newly-discovered, privately reported vulnerability. A buffer overrun vulnerability exists in the processing of JPEG image formats that could allow remote code execution on an affected system. The vulnerability and more details on this update are documented in Microsoft Security Bulletin MS04-028 at KB article 833987.

        Note When these types of Visual FoxPro 8.0 applications are installed on Windows XP or Windows Server 2003, they will generally use the operating system version of the vulnerable component. If you use these types of programs on Windows XP, Windows XP Service Pack 1 or Windows Server 2003, make sure that you install the operating system version of the security update. If you use these types of programs on other operating systems, make sure that you install this update.

Popular Downloads

Loading your results, please wait...

Free PC updates

  • Security patches
  • Software updates
  • Service packs
  • Hardware drivers