Developer Tools

    Microsoft ASP.NET Futures (May 2007)

    Language:
    English
    Contains features that are in development for ASP.NET.
    • Version:

      1

      File Name:

      ASPNETFutures.msi

      Date Published:

      5/14/2007

      File Size:

      50.4 MB

        The Microsoft ASP.NET Futures May 2007 (“Futures”) release contains an early developer preview of features providing a wide range of new functionality for both ASP.NET and Silverlight™. The functionality in the Futures release includes early experimental versions of features currently being considered for future versions of ASP.NET and the .NET Framework. The Futures releases assume prior knowledge of the core features of ASP.NET including the previous ASP.NET AJAX Futures January CTP.

        Features in this release include ASP.NET Silverlight server controls, new functionality for ASP.NET AJAX Extensions, dynamic data controls, enhancements to dynamic languages, and more.
    • Supported Operating System

      Windows Server 2003, Windows Vista, Windows XP

        • Net Framework 2.0 or later.

        • Microsoft ASP.NET AJAX Extensions 1.0
        • Visual Studio 2005 or Visual Web Developer 2005 Express Edition
      • Download the installation package to your computer and save it. You can then run the installation package and follow the instructions to install the ASP.NET Futures (May 2007) release.
      • If you have previously installed any earlier versions of ASP.NET CTP or IronPython CTP, you must uninstall these previous versions before installing the Futures release.

        If you are running Vista, you must run the installer from a command prompt with administrative rights. Follow these steps:
        1. From the Windows Start menu, click Accessories, right-click the command prompt, and then click Run as administrator.
        2. Change to the folder where you downloaded the .msi file.
        3. Run the following command:

          msiexec /i ASPNETFutures.msi
        The Futures release requires an update to the .NET Framework version 2.0 to support dynamic languages and dynamic data controls. (This update is not required for other ASP.NET Futures (May 2007) features.) Instructions for installing the update depend on which version of Windows you are using.

        • For users who are not running Vista: If your computer does not have the update installed, you will be prompted to install the .NET Framework 2.0 update (KB925675) at the beginning of the installation process.
        • Note  If you have installed ASP.NET version 2.0.50727.213 or higher on a computer that is running Windows Server 2003 or Windows XP, this step will be skipped.


        • For users who are running Vista: You can update your computer by installing the .NET Framework version 3.5 Beta 1 release from the Microsoft Download Web site. Alternatively, you can install the Beta version of Visual Studio Code Name "Orcas," which also installs the required update. If you do not have the latest update installed, ASP.NET raises an error when you attempt to run an application that contains dynamic data controls or uses a dynamic language. Note  If you have installed ASP.NET version 2.0.50727.786 or higher on a computer that is running Windows Vista, this step will be skipped.

    Popular downloads

    Loading your results, please wait...

    Free PC updates

    • Security patches
    • Software updates
    • Service packs
    • Hardware drivers

    Microsoft suggests

    Download free tools to build apps for Windows.
    Download free tools to build apps for Windows
    Develop apps that reach the entire family of Windows devices.
    Get started