• Utilizzando questo sito accetti l’uso di cookie per analisi, contenuti personalizzati e pubblicità.

Unified Communications Managed API 4.0 Runtime

Seleziona lingua:
Unified Communications Managed API (UCMA) 4.0 è una piattaforma di codice gestito che gli sviluppatori utilizzano per creare applicazioni che forniscono l'accesso e il controllo su informazioni avanzate sulla presenza, messaggistica istantanea, chiamate telefoniche e videochiamate e audio e videoconferenze.
  • Versione:

    8308.0

    Nome file

    UcmaRuntimeSetup.exe

    Data di pubblicazione:

    11/10/2012

    Dimensione file:

    240.2 MB

      UCMA offre una piattaforma di codice gestito flessibile per le comunicazioni unificate e la collaborazione che consente agli sviluppatori di implementare servizi di livello medio abilitati per la comunicazione e la collaborazione avvantaggiandosi dell'investimento effettuato in Lync Server. Consente inoltre di abilitare scenari di comunicazione unificata di uguale o migliore livello di quelli di Microsoft.

      Un amministratore che sta preparando l'installazione di un'applicazione abilitata per UCMA in un computer di distribuzione deve scaricare e installare UcmaRuntimeSetup.exe. L'installazione di UCMA 4.0 Runtime fornisce tutte le funzionalità relative a UCMA necessarie per un'applicazione abilitata per UCMA.

  • Sistema operativo supportato

    Windows Server 2008 R2 SP1; Windows Server 2012


      Requisiti di UCMA 4.0 Runtime

      Di seguito sono riportati i requisiti hardware e software per l'installazione di UCMA 4.0 Runtime.
      • La piattaforma di destinazione deve essere un computer a 64 bit
      • Service Pack di Microsoft .NET Framework 4.5 o versioni successive.
        • Windows Server 2008 R2 SP1 e Windows 7 SP1: UcmaRuntimeSetup.exe richiede che Microsoft .NET Framework 4.5 sia installato prima dell'avvio di UCMARuntimeSetup.exe.
        • In Windows Server 2012 e Windows 8 Microsoft .NET Framework 4.5 è già incluso.
      • Software antivirus
        • Non è consigliabile installare un software antivirus nei computer che eseguono Microsoft Lync Server 2010 o Microsoft Lync Server 2013. Per le prestazioni ottimali di un server che deve eseguire un software antivirus, includere tutti i computer Communications Server/Lync Server nell'elenco delle eccezioni del software antivirus.
    • Installazione dei componenti di UCMA 4.0 Runtime e di Microsoft Lync Server 2013

        Installazione di UCMA 4.0 Runtime

        Per installare UCMA 4.0 Runtime è necessario disporre di autorizzazioni elevate.

          Per installare UCMA 4.0 Runtime
          1. Scaricare UcmaRuntimeSetup.exe.
          2. Avviare UcmaRuntimeSetup.exe e seguire le indicazioni fornite nelle schermate per accettare il contratto di licenza con l'utente finale (EULA). L'installazione guidata installerà tutti i componenti necessari.
          3. Seguire le istruzioni visualizzate sullo schermo per completare l'installazione.
          Nota: UcmaRuntimeSetup.exe le versioni in lingua inglese dei motori di riconoscimento vocale e sintesi vocale. Nella schermata finale del programma di installazione è disponibile un collegamento che è possibile utilizzare per scaricare ulteriori motori per altre lingue.

          Nota: sono richieste ulteriori procedure per l'installazione di Microsoft Lync Server 2013, Core Components (OCSCore.msi). I passaggi necessari sono descritti più avanti in questo argomento.


        Componenti di UCMA 4.0 Runtime

        UcmaRuntimeSetup.exe installa i componenti seguenti.
        • o Pacchetto Microsoft VC ++ 11 Redistributable -x64
          • Microsoft Unified Communications Managed API 4.0 Runtime è basato su Microsoft .NET Framework 4.5 e Visual C++ 11 Redistributable Package (x64).
        • Pacchetto Microsoft Server Speech Platform Runtime (x64)
        • Microsoft Server Speech Recognition Language - TELE (en-US)
        • Microsoft Server Speech Text To Speech Voice (en-US, Helen)
        • Microsoft Server Speech Platform VXML Runtime (x64)
        • Microsoft Lync Server 2013, Bootstrapper Prerequisites Installer Package
          • Copia Lync Server 2013 Core Components MSI (OCSCore.msi) e i relativi prerequisiti. OCSCore.msi consente l'installazione di cmdlet PowerShell specifici di Communications Server dal computer locale. OCSCore.msi consente inoltre di installare la replica di Central Management Store che è richiesta dalle applicazioni UCMA con provisioning automatico.
        Nota: le installazioni affiancate di UCMA 3.0 e UCMA 4.0 non sono supportate.

        Installazione dei componenti di Microsoft Lync Server 2013

        OCSCore.msi deve essere installato mediante il pacchetto di Windows Installer per i prerequisiti del programma di avvio (Bootstrapper Prerequisites Installer Package) installato da UcmaRuntimeSetup.exe (opzione consigliata) o mediante l'installazione degli strumenti di amministrazione disponibili nel DVD di Lync Server.

          Per installare Microsoft Lync Server 2013 Core Components
          1. Verificare che Microsoft PowerShell 3.0 sia installato nel computer di distribuzione.
            1. Windows 8 e Windows Server 2012
              • Questa versione del sistema operativo è inclusa in PowerShell 3.0
            2. Windows Server 2008 R2 SP1 e Windows 7 SP1
          2. Individuare il file OCSCore.msi passando a %Unità installazione%\ProgramData\Microsoft\Lync Server\Deployment\cache\[Versione build]\Setup\.


          3. Nota: per impostazione predefinita, la cartella ProgramData è nascosta e pertanto potrebbe non essere visualizzata in Esplora risorse.

          4. Avviare OCSCore.msi e utilizzare le impostazioni predefinite indicate nella procedura guidata.
          Per ulteriori informazioni sull'attivazione di un'applicazione UCMA, vedere "Attivazione di un'applicazione attendibile UCMA 4.0 Core" nella documentazione relativa all'SDK di Unified Managed API 4.0 Core.


        Disinstallazione di UCMA 4.0 Runtime e Bootstrapper Prerequisites Installer

        Quando un'applicazione del cliente viene disinstallata, la procedura di disinstallazione dell'applicazione non deve disinstallare automaticamente alcun componente necessario (ad esempio .NET Framework 4.5, Visual C++ 11 Redistributable Package o UCMA 4.0 Runtime), in quanto potrebbero essere necessari per il funzionamento di altre applicazioni. Un amministratore che ha verificato che non esistono dipendenze può seguire le istruzioni fornite nella procedura seguente per disinstallare UCMA 4.0 Runtime.

          Per disinstallare UCMA 4.0 Runtime e Bootstrapper Prerequisites Installer
          1. Passare a Programmi e funzionalità nel Pannello di controllo.
          2. Nel menu di scelta rapida per la voce Microsoft Unified Communications Managed API 4.0, Runtime scegliere Disinstalla.
          3. Verrà visualizzata una procedura guidata intitolata "Disinstallazione di Unified Communications Managed API 4.0, Runtime". Seguire le istruzioni visualizzate sullo schermo per completare la disinstallazione.
          4. Nel menu di scelta rapida per la voce Lync Server 2013, Bootstrapper Prerequisites Installer Package scegliere Disinstalla per rimuovere il pacchetto di Windows Installer.
          Nota: la disinstallazione di Bootstrapper Prerequisites Installer Package non comporta la disinstallazione automatica dei componenti software installati individualmente dall'utente, ad esempio Lync Server 2013, Core Components (OCSCore.msi) e altri.