*
Microsoft TechNet*
resultados de Bing
|Suscríbase|Descarga|Contáctenos|Simplified

Boletín de seguridad de Microsoft MS04-040

Actualización de seguridad acumulativa para Internet Explorer (889293)

Publicado: 1 de diciembre de 2004
Versión: 1.0

Resumen

Quién debería leer este documento: Los clientes que usen Microsoft Windows

Consecuencia de la vulnerabilidad: Ejecución remota de código

Gravedad máxima: Crítica

Recomendación: Los clientes deberían instalar la actualización inmediatamente.

Actualizaciones de seguridad reemplazadas: Esta actualización sustituye a la actualización que se incluye en el boletín de seguridad de Microsoft MS04-038. Esta actualización es una actualización de seguridad acumulativa.

Advertencias: En el artículo 889293 de Microsoft Knowledge Base se señalan los problemas conocidos actuales que pueden experimentar los clientes al instalar esta actualización de seguridad. Se documentan asimismo las soluciones propuestas.

Importante: Esta actualización no incluye revisiones (hotfixes) proporcionadas desde la publicación de MS04-004 o MS04-038. Los clientes que recibieron revisiones de Microsoft o de los proveedores de soporte después de la publicación de MS04-004 o MS04-038 no deben instalar esta actualización. En vez de ello, deben implementar la actualización 889669.

Esta actualización incluye varios cambios de seguridad y funcionalidad que están documentados en la sección Preguntas más frecuentes de esta actualización.

Ubicaciones de descarga de la actualización de seguridad y software probado:

Software afectado:

Microsoft Windows NT Server 4.0 Service Pack 6a

Microsoft Windows NT Server 4.0 Terminal Server Edition Service Pack 6

Microsoft Windows 2000 Service Pack 3 y Microsoft Windows 2000 Service Pack 4

Microsoft Windows XP Service Pack 1

Service Pack 1 de Microsoft Windows XP 64-Bit Edition Gold

Microsoft Windows 98, Microsoft Windows 98 Segunda edición (SE) y Microsoft Windows Millennium Edition (Me): para obtener detalles acerca de estos sistemas operativos revise la sección P+F de este boletín.

Componentes afectados:

Internet Explorer 6 Service Pack 1 en Microsoft Windows 2000 Service Pack 3, Microsoft Windows 2000 Service Pack 4 o Microsoft Windows XP Service Pack 1: Descargar la actualización

Internet Explorer 6 Service Pack 1 en Microsoft Windows NT Server 4.0 Service Pack 6a, Microsoft Windows NT Server 4.0 Terminal Service Edition Service Pack 6, Microsoft Windows 98, Microsoft Windows 98 SE o Microsoft Windows Me: Descargar la actualización

Internet Explorer 6 para Windows XP Service Pack 1 (64-Bit Edition): Descargar la actualización

Los programas de esta lista han sido probados para determinar si las versiones están afectadas. Por lo que se refiere a otras versiones, quizá ya no sean compatibles con las actualizaciones de seguridad o no se vean afectadas. Para determinar el ciclo de vida del soporte técnico de su producto y versión, visite el sitio Web Ciclo de vida del soporte técnico de Microsoft.

Información general

Resumen ejecutivo

Resumen ejecutivo:

Esta actualización resuelve una vulnerabilidad descubierta recientemente, de la que se ha informado de forma pública. Existe una vulnerabilidad en Internet Explorer que podría permitir la ejecución remota de código en el sistema afectado. La vulnerabilidad se documenta en este boletín, en el apartado Detalles de la vulnerabilidad.

Si un usuario inicia sesión con privilegios administrativos, un intruso que aprovechara esta vulnerabilidad podría lograr el control completo de un sistema afectado y, por ejemplo, instalar programas; ver, cambiar o eliminar datos; o crear cuentas nuevas con todos los privilegios. Por tanto, los usuarios cuyas cuentas estén configuradas con pocos privilegios en el sistema correrían un riesgo menor que aquellos que cuenten con privilegios administrativos.

Microsoft recomienda a sus clientes que instalen la actualización inmediatamente.

Gravedad e identificadores de vulnerabilidad:

Identificadores de vulnerabilidadConsecuencia de la vulnerabilidadInternet Explorer 6 SP1 (todas las versiones anteriores a Windows Server 2003)

Vulnerabilidad de elementos HTML: CAN-2004-1050

Ejecución remota de código

Crítica

Esta clasificación está basada en los tipos de sistemas afectados por la vulnerabilidad, sus patrones típicos de implementación y el efecto que podría tener un ataque en el que se aprovechara la vulnerabilidad.

Preguntas más frecuentes (P+F) relacionadas con esta actualización de seguridad

¿Qué actualizaciones reemplaza esta versión?
Esta actualización de seguridad reemplaza a varios boletines de seguridad anteriores para Internet Explorer. El boletín de seguridad más reciente y las versiones de Internet Explorer afectadas se enumeran en la siguiente tabla.

ID de boletínInternet Explorer 6 SP1 (todas las versiones anteriores a Windows Server 2003)

MS04-038

Reemplazado

He recibido una revisión de Microsoft o del proveedor de compatibilidad desde la publicación del boletín MS04-004. ¿Está incluida en esta actualización de seguridad?
La mayor parte de las revisiones para Internet Explorer no están incluidas en la actualización de seguridad MS04-040 para Internet Explorer 6 Service Pack 1 en Windows 2000 Service Pack 3, Windows 2000 Service Pack 4, Windows XP, Windows XP Service Pack 1, Windows NT Server 4.0 Service Pack 6a, Windows NT Server 4.0 Terminal Server Edition Service Pack 6, Windows 98, Windows 98 Segunda Edición y Windows Me. Al instalar cualquiera de las actualizaciones de seguridad de MS04-040 para Internet Explorer 6 SP1, se eliminará toda revisión de Internet Explorer publicada desde MS04-004, si la revisión sustituye a cualquiera de los archivos mencionados en la sección Información de actualización de seguridad de este boletín.

A partir de MS04-038, las revisiones acumulativas para Internet Explorer están disponibles en un conjunto de actualizaciones independiente que incluye tanto las revisiones acumulativas como las correcciones de seguridad incluidas en la actualización de seguridad más reciente para Internet Explorer. Por ejemplo, el conjunto de actualizaciones 871260 incluye las correcciones de seguridad acumulativas en MS04-038 y las revisiones publicadas desde MS04-004. El conjunto de actualizaciones 889669 incluye las correcciones de seguridad acumulativas en MS04-040 y las revisiones publicadas desde MS04-004. Para obtener más información acerca de las revisiones incluidas en el conjunto de actualizaciones 889669, así como las instrucciones para obtener e implementar dicho conjunto, póngase en contacto con su proveedor de soporte de Microsoft o consulte el artículo 889669 de Microsoft Knowledge Base.

¿Contiene esta actualización algún otro cambio en la funcionalidad?
Sí. Además de los cambios que se indican en el apartado Detalles de la vulnerabilidad de este boletín, esta actualización presenta los siguientes cambios de funcionalidad:

Al igual que las anteriores actualizaciones de seguridad acumulativas para Internet Explorer publicadas desde el boletín MS03-004, ésta provocará una interrupción en el funcionamiento del control window.showHelp( ) si no se ha aplicado la actualización de la ayuda HTML. Si ha instalado el control actualizado de la Ayuda HTML mencionado en el artículo 811630 de Microsoft Knowledge Base, podrá utilizar las funciones de la Ayuda HTML después de instalar esta actualización.

Al igual que las anteriores actualizaciones de seguridad acumulativas para Internet Explorer, MS04-004, esta actualización no permite que se visiten sitios Web con las direcciones URL de tipo "nombredeusuario:contraseña@host.com" para XMLHTTP. Hemos creado una actualización de MSXML que resuelve este problema específicamente para XMLHTTP. Para obtener más información, vea el artículo 832414 de Microsoft Knowledge Base.

¿Contiene esta actualización algún otro cambio en relación con la seguridad?
Sí. Además de los cambios que se indican en la sección Detalles de la vulnerabilidad de este boletín, esta actualización presenta los siguientes cambios de seguridad:

Al igual que las anteriores actualizaciones de seguridad acumulativas para Internet Explorer publicadas desde el boletín MS04-004, ésta también incluye un cambio en la funcionalidad de una característica de autenticación de texto simple de Internet Explorer. La actualización evita que se traten los nombres de usuario y las contraseñas de las direcciones URL de tipo HTTP, HTTP con Nivel de sockets seguro (SSL) o HTTPS en Microsoft Internet Explorer. La sintaxis de dirección URL siguiente ya no se admite en Internet Explorer ni en el Explorador de Windows una vez instalada esta actualización de software:

http(s)://nombredeusuario:contraseña@servidor/recurso.ext

Para obtener más información sobre este cambio, consulte el artículo 834489 de Microsoft Knowledge Base.

¿Cómo afecta el servicio técnico ampliado de Windows 98, Windows 98 Segunda edición y Windows Millennium Edition a la publicación de actualizaciones de seguridad para estos sistemas operativos?
Microsoft sólo publicará actualizaciones de seguridad para problemas de seguridad críticos. Los problemas de seguridad no críticos no se ofrecen durante este periodo de servicio técnico. Para obtener más información acerca de las directivas del ciclo de vida del soporte técnico de Microsoft correspondientes a estos sistemas operativos, visite este sitio Web de asistencia de Microsoft.

Para obtener más información acerca de la clasificación de gravedad, visite el siguiente sitio Web de Microsoft TechNet.

Nota Las actualizaciones de seguridad crítica para estas plataformas pueden no estar disponibles en este momento con el resto de las actualizaciones de seguridad que se proporcionan en este boletín de seguridad. Estarán disponibles lo antes posible una vez que se creen. Cuando estas actualizaciones de seguridad estén disponibles, podrá descargarlas únicamente en el sitio Web de Windows Update.

¿Están afectados Windows 98, Windows 98 Segunda edición o Windows Millennium Edition de forma crítica por alguna vulnerabilidad tratada en este boletín de seguridad?
Sí. Windows 98, Windows 98 Segunda edición y Windows Millennium Edition están afectados gravemente por esta vulnerabilidad. Las actualizaciones de seguridad críticas para estas plataformas pueden no estar disponibles en este momento con el resto de actualizaciones de seguridad proporcionadas en este boletín de seguridad. Estarán disponibles lo antes posible una vez que se creen. Cuando estas actualizaciones de seguridad estén disponibles, podrá descargarlas únicamente en el sitio Web de Windows Update. Para obtener más información acerca de clasificación de gravedad, visite el siguiente sitio Web.

Sigo usando Microsoft Windows NT 4.0 Workstation Service Pack 6a o Windows 2000 Service Pack 2, pero el período extendido de soporte técnico de la actualización de seguridad finalizó el 30 de junio de 2004. ¿Qué debo hacer?
Windows NT 4.0 Workstation Service Pack 6a y Windows 2000 Service Pack 2 han llegado al final de sus ciclos de vida, según se ha explicado anteriormente, y Microsoft amplió el período de soporte técnico hasta el 30 de junio de 2004.

Los clientes que tengan esas versiones de los sistemas operativos deberían plantearse la migración a versiones con soporte técnico para evitar la exposición a futuras vulnerabilidades. Para obtener más información acerca del ciclo de vida del soporte técnico de los productos de Windows, visite el sitio Web Ciclo de vida del soporte técnico de Microsoft. Para obtener más información acerca de la ampliación del período de soporte técnico de las actualizaciones de seguridad correspondientes a estas versiones de sistemas operativos, visite el siguiente sitio Web Servicios de soporte técnico de Microsoft.

Los clientes que requieran soporte técnico adicional para el SP6a de Windows NT Workstation 4.0 deben ponerse en contacto con su representante del equipo de cuentas de Microsoft, con su administrador técnico de cuentas o con el representante del socio de Microsoft apropiado para consultar las opciones de soporte personalizadas disponibles. Los clientes con un contrato Alliance, Premier o Authorized pueden ponerse en contacto con su oficina de ventas local de Microsoft. Para obtener información de contacto, visite el sitio Web de información en todo el mundo de Microsoft, seleccione el país y, a continuación, haga clic en Ir para ver la lista de números de teléfono. Cuando llame, diga que desea hablar con el administrador de ventas local de soporte técnico Premier.

Para obtener más información, consulte las Preguntas más frecuentes del sistema operativo Windows.

Sigo utilizando Windows XP, pero el período extendido de soporte técnico de la actualización de seguridad finalizó el 30 de septiembre de 2004. ¿Qué debo hacer?
La versión original de Windows XP, que normalmente se denomina Windows XP Gold o versión Windows XP Release to Manufacturing (RTM), llegó al final de la ampliación del ciclo de vida de soporte técnico de actualizaciones de seguridad el 30 de septiembre de 2004.

Los clientes que tengan esas versiones de los sistemas operativos deberían plantearse la migración a versiones con soporte técnico para evitar la exposición a futuras vulnerabilidades. Para obtener más información acerca del ciclo de vida del soporte técnico de los productos de Windows, visite el sitio Web Ciclo de vida del soporte técnico de Microsoft. Para obtener más información acerca de la ampliación del período de soporte técnico de las actualizaciones de seguridad correspondientes a estas versiones de sistemas operativos, visite el siguiente sitio Web Servicios de soporte técnico de Microsoft.

Los clientes que requieran soporte técnico adicional para Windows XP RTM deben ponerse en contacto con su representante del equipo de cuentas de Microsoft, con su administrador técnico de cuentas o con el representante del socio de Microsoft apropiado para consultar las opciones de soporte personalizado disponibles. Los clientes con un contrato Alliance, Premier o Authorized pueden ponerse en contacto con su oficina de ventas local de Microsoft. Para obtener información de contacto, visite el sitio Web de información en todo el mundo de Microsoft, seleccione el país y, a continuación, haga clic en Ir para ver la lista de números de teléfono. Cuando llame, diga que desea hablar con el administrador de ventas local de soporte técnico Premier.

Para obtener más información, consulte las Preguntas más frecuentes del sistema operativo Windows.

¿Por qué son diferentes para esta actualización los parámetros de instalación de línea de comandos para los sistemas operativos Windows 2000 y Windows XP en comparación con la actualización de seguridad acumulativa de Internet Explorer, MS04-025?
A partir de MS04-038, los paquetes para Windows 2000 y Windows XP Service Pack 1 utilizan una tecnología de instalación nueva: Update.exe. Por tanto, las opciones de instalación son diferentes a las de versiones anteriores. Adicionalmente, como parte de la transición a la tecnología de instalación Update.exe, el número del artículo de Knowledge Base de esta actualización ya no se mostrará en la ventana Acerca de del menú Ayuda de Internet Explorer. Para obtener más información acerca de los parámetros de línea de comandos utilizados en esta versión, consulte la sección Información sobre la actualización de seguridad de este boletín. Para obtener más información acerca de Update.exe, visite el siguiente sitio Web de Microsoft.

¿Por qué hay dos versiones de la actualización de Internet Explorer 6 Service Pack 1?
Se ha creado un paquete independiente para Internet Explorer 6 Service Pack 1 cuando se utiliza en Windows NT Server Service Pack 6a, Windows 98, Windows 98SE y Windows Me. Esta actualización utiliza la misma tecnología de instalación que las versiones anteriores: Iexpress. Para obtener información detallada acerca de esta actualización de seguridad en dichos sistemas operativos, consulte las secciones Información sobre la actualización de seguridad de este boletín. Para obtener más información acerca de Iexpress, consulte el artículo 197147 de Microsoft Knowledge Base.

¿Se puede utilizar Microsoft Baseline Security Analyzer (MBSA) para determinar si esta actualización es necesaria?
Sí. MBSA determinará si la actualización es necesaria. Para obtener más información acerca de MBSA, visite el sitio Web de MBSA.

Nota Después del 20 de abril de 2004, el archivo Mssecure.xml utilizado por MBSA 1.1.1 y por las versiones anteriores ya no se actualiza con los nuevos datos del boletín de seguridad. Por lo tanto, las detecciones realizadas con MBSA 1.1.1 o una versión anterior después de esa fecha serán incompletas. Todos los usuarios deben actualizar a MBSA 1.2 porque permite realizar la detección de actualizaciones de seguridad con más precisión y admite más productos. Los usuarios pueden descargar MBSA 1.2 del sitio Web de MBSA. Para obtener más información acerca del soporte técnico de MBSA, visite el siguiente sitio Web de preguntas y respuestas de Microsoft Baseline Security Analyzer 1.2.

¿Se puede utilizar Systems Management Server (SMS) para determinar si esta actualización es necesaria?
Tal como se indica en la sección Componentes afectados de este boletín, esta publicación incluye dos paquetes para Internet Explorer 6 SP1. Uno de ellos está diseñado para Windows 2000 y Windows XP Service Pack 1. Este paquete utiliza la tecnología de instalación Update.exe mencionada anteriormente. El segundo paquete está diseñado para Windows NT, Windows 98 y Windows Me. MBSA no puede determinar la actualización de Internet Explorer 6 SP1 requerida para un sistema operativo determinado. Se ha creado un paquete de implementación SMS que contiene ambas versiones de las actualizaciones de Internet Explorer 6 SP1. Cuando se implementa con SMS, este paquete detecta el sistema operativo e instala la versión correcta de la actualización para el mismo. Cuando se utiliza con SMS, MBSA indica a los administradores de SMS que implementen este paquete de implementación SMS. Para obtener más información acerca de esta actualización, consulte el artículo 887437 de Microsoft Knowledge Base.

Detalles de la vulnerabilidad

Vulnerabilidad de elementos HTML: CAN-2004-1050:

Existe una vulnerabilidad de ejecución remota de código en Internet Explorer que podría permitir la ejecución remota de código en el sistema afectado. Un intruso podría aprovechar esta vulnerabilidad mediante la construcción de una página Web malintencionada que llegara a lograr permitir la ejecución de código remoto cuando un usuario visitara un sitio Web malintencionado. Un atacante que aprovechara esta vulnerabilidad podría lograr el control completo de un sistema afectado.

Factores mitigantes de la vulnerabilidad de elementos HTML - CAN-2004-1050:

En el caso de un ataque basado en Web, el intruso tendría que alojar un sitio Web que contuviera una página Web para aprovechar esta vulnerabilidad. El atacante no podría obligar a los usuarios a visitar un sitio Web malintencionado. Por lo tanto, tendría que atraerlos al sitio Web; para ello debería, por ejemplo, incitarles a hacer clic en un vínculo que les llevara al sitio Web del atacante.

Un intruso que aprovechara con éxito esta vulnerabilidad podría obtener los mismos privilegios que el usuario. Por tanto, los usuarios cuyas cuentas estén configuradas con pocos privilegios en el sistema correrían un riesgo menor que aquellos que cuenten con privilegios administrativos.

De forma predeterminada, Outlook Express 6, Outlook 2002 y Outlook 2003 abren los mensajes de correo electrónico HTML dentro de la zona Sitios restringidos. Además, Outlook 98 y Outlook 2000 abren los mensajes de correo electrónico HTML dentro de la zona Sitios restringidos si se ha instalado la Actualización de seguridad para correo electrónico de Outlook. Outlook Express 5.5 Service Pack 2 abre el correo electrónico en formato HTML en la zona Sitios restringidos si se ha instalado el boletín de seguridad de Microsoft MS04-018. La zona Sitios restringidos ayuda a reducir los ataques que podrían aprovechar esta vulnerabilidad.

El riesgo de sufrir un ataque mediante un mensaje de correo electrónico HTML se puede reducir de forma significativa si se cumplen todas las siguientes condiciones:

Aplique la actualización incluida con el boletín de seguridad de Microsoft MS03-040 o una actualización de seguridad acumulativa posterior para Internet Explorer.

Use Outlook Express 5.5 Service Pack 2 o posterior y aplique la actualización que se incluye en el boletín de seguridad de Microsoft MS04-018 o una actualización de seguridad acumulativa posterior para Outlook Express.

Use Microsoft Outlook 98 y Outlook 2000 con la actualización de seguridad para el correo electrónico de Microsoft Outlook.

Use Microsoft Outlook Express 6 o posterior, o Microsoft Outlook 2000 Service Pack 2 o posterior en su configuración predeterminada.

Los siguientes productos no se ven afectados por esta vulnerabilidad.

Internet Explorer 5.01 Service Pack 3

Internet Explorer 5.01 Service Pack 4

Internet Explorer 5.5 Service Pack 2

Internet Explorer 6 en Windows Server 2003

Internet Explorer 6 en Windows XP Service Pack 2

Soluciones para la vulnerabilidad de elementos HTML - CAN-2004-1050:

Microsoft ha probado las siguientes soluciones provisionales. Aunque estas soluciones provisionales no corrigen la vulnerabilidad subyacente, ayudan a bloquear los tipos de ataque conocidos. Cuando una solución reduce la funcionalidad, se identifica a continuación.

Instale la Actualización de seguridad para correo electrónico de Outlook si está usando Outlook 2000 SP1 o una versión anterior.

De forma predeterminada, Outlook Express 6, Outlook 2002 y Outlook 2003 abren los mensajes de correo electrónico HTML dentro de la zona Sitios restringidos. Además, Outlook 98 y Outlook 2000 abren los mensajes de correo electrónico HTML dentro de la zona Sitios restringidos si se ha aplicado la Actualización de seguridad para correo electrónico de Outlook.

Los clientes que utilicen cualquiera de estos productos correrán un riesgo reducido de un ataque mediante correo electrónico que intente aprovechar estos puntos vulnerables a no ser que hagan clic en un vínculo malintencionado del mensaje.

Instale la actualización incluida en el boletín de seguridad de MicrosoftMS04-018 si está usando Outlook Express 5.5 SP2.

Outlook Express 5.5 Service Pack 2 abre el correo electrónico en formato HTML en la zona Sitios restringidos si se ha aplicado la actualización incluida en el boletín de seguridad de Microsoft MS04-018.

Los clientes que utilicen cualquiera de estos productos correrán un riesgo reducido de un ataque mediante correo electrónico que intente aprovechar estos puntos vulnerables a no ser que hagan clic en un vínculo malintencionado del mensaje.

Lea los mensajes de correo electrónico como texto sin formato si está utilizando Outlook 2002 o una versión posterior, o bien Outlook Express 6 SP1 o una versión posterior, para protegerse del tipo de ataque mediante correo electrónico HTML.

Los usuarios de Microsoft Outlook 2002 que han aplicado Office XP Service Pack 1 o una versión posterior, y los usuarios de Outlook Express 6 que han aplicado Internet Explorer 6 Service Pack 1 pueden habilitar una característica para ver los mensajes de correo electrónico que no estén firmados digitalmente o que no estén cifrados sólo en texto sin formato.

A los mensajes de correo electrónico firmados digitalmente o cifrados no les afecta esta configuración y pueden leerse en sus formatos originales. Para obtener más información acerca de cómo habilitar esta configuración en Outlook 2002, vea el artículo 307594 de Microsoft Knowledge Base.

Para obtener más información acerca de esta configuración de Outlook Express 6, vea el artículo 291387 de Microsoft Knowledge Base.

Alcance de la solución: Los mensajes vistos como texto sin formato no contienen imágenes, fuentes especiales, animaciones ni contenido enriquecido. Además:

Los cambios se aplican al panel de vista previa y a los mensajes abiertos.

Las imágenes se conservan como archivos adjuntos.

Como el formato del mensaje sigue siendo de texto enriquecido o HTML en el almacén, el modelo de objetos (soluciones de código personalizado) puede comportarse inesperadamente.

Preguntas más frecuentes sobre la vulnerabilidad de elementos HTML - CAN-2004-1050:

¿Cuál es el alcance de esta vulnerabilidad?
Se trata de una vulnerabilidad de ejecución remota de código. Si un usuario inicia sesión con privilegios administrativos, un intruso que aprovechara esta vulnerabilidad podría lograr el control completo de un sistema afectado para, por ejemplo, instalar programas, ver, cambiar o eliminar datos, o crear cuentas nuevas que tienen todos los privilegios. Por tanto, los usuarios cuyas cuentas estén configuradas con pocos privilegios en el sistema correrían un riesgo menor que aquellos que cuenten con privilegios administrativos.

¿Cuál es la causa de esta vulnerabilidad?
La existencia de un búfer sin comprobar en el procesamiento de Internet Explorer de determinados elementos HTML como, por ejemplo, FRAME e IFRAME.

¿Qué son los elementos IFRAME?
Inline Floating Frames (IFRAME) es una tecnología que permite a los autores de sitios Web disponer de un mayor control del diseño y la interacción de sus páginas Web. Para obtener más información acerca de elementos IFRAME, visite este sitio Web de Microsoft Developer Network (MSDN).

¿Cómo podría aprovechar un intruso la vulnerabilidad?
Un intruso podría aprovechar esta vulnerabilidad creando una página Web o un mensaje de correo electrónico HTML malintencionado para, seguidamente, incitar al usuario a visitar la página o leer el mensaje. Cuando el usuario visita la página o abre el mensaje de correo electrónico, el intruso puede obtener acceso a la información de otros sitios Web o archivos locales del sistema o provocar la ejecución de código malintencionado como si fuera el usuario que inició la sesión de forma local.

¿Qué sistemas están más expuestos a esta vulnerabilidad?
Para que se produzca una acción de este tipo, se requiere que el usuario esté leyendo correo electrónico o visitando sitios Web. Por lo tanto, cualquier sistema en el que se lea correo electrónico o se utilice Internet Explorer de forma habitual (como estaciones de trabajo de usuarios y servidores de Terminal Server) está expuesto a estos puntos vulnerables. Los sistemas que no se suelen utilizar para leer correo electrónico o para visitar sitios Web (como la mayoría de los sistemas de servidor) sufren un riesgo mínimo.

Debe tenerse en cuenta que los elementos FRAME no se procesan en la zona restringida, que es la zona predeterminada donde Outlook Express y Outlook abren mensajes de correo electrónico HTML. El aprovechamiento de esta vulnerabilidad por correo electrónico requiere que el usuario haga clic en el vínculo malintencionado del mensaje. Vea la sección Soluciones de este boletín para obtener más información.

¿Están afectados Windows 98, Windows 98 Segunda edición o Windows Millennium Edition de forma crítica por esta vulnerabilidad?
Sí. Windows 98, Windows 98 Segunda edición y Windows Millennium Edition están afectados gravemente por esta vulnerabilidad. Las actualizaciones de seguridad críticas para estas plataformas pueden no estar disponibles en este momento con el resto de las actualizaciones de seguridad proporcionadas en este boletín de seguridad. Estarán disponibles lo antes posible una vez que se creen. Cuando estas actualizaciones de seguridad estén disponibles, podrá descargarlas únicamente en el sitio Web de Windows Update. Para obtener más información acerca de la clasificación de gravedad, visite este sitio Web de Microsoft.

¿Cómo funciona esta actualización?
Esta actualización elimina la vulnerabilidad modificando el modo en que Internet Explorer valida la longitud de los mensajes al procesar elementos HTML.

En el momento de emitir este boletín de seguridad, ¿se había divulgado ya esta vulnerabilidad?
Sí. Esa vulnerabilidad ya se ha divulgado. Se le ha asignado el número de vulnerabilidad y exposición común CAN-2004-1050.

En el momento de publicar este boletín de seguridad, ¿había recibido Microsoft algún informe que indicase que se estaba utilizando esta vulnerabilidad?
Sí. En el momento de emitir este boletín de seguridad, ¿había recibido Microsoft alguna información que indicara que se estaba utilizando esta vulnerabilidad?

Información sobre la actualización de seguridad

Plataformas de instalación y requisitos previos:

Para obtener información adicional acerca de cómo determinar qué versión de Internet Explorer está ejecutando, consulte el artículo 164539 de Microsoft Knowledge Base.

Para obtener información acerca de la actualización de seguridad específica para su sistema, haga clic en el vínculo apropiado:

Internet Explorer 6 SP1 para Windows XP Service Pack 1 y Windows 2000 (todas las versiones)

Requisitos previos
Para instalar las versiones para Internet Explorer 6 Service Pack 1 (SP1) de esta actualización, debe ejecutar Internet Explorer 6 SP1 (versión 6.00.2800.1106) en una de las siguientes versiones de Windows:

Microsoft Windows 2000 Service Pack 3 y Service Pack 4

Microsoft Windows XP Service Pack 1

Service Pack 1 de Microsoft Windows XP 64-Bit Edition Gold

Información sobre la instalación

Esta actualización de seguridad admite los siguientes parámetros de instalación:

/help  Muestra las opciones de la línea de comandos.

Modos de instalación

/quiet Modo silencioso (sin interacción del usuario ni mensajes).

/passive Modo desatendido (sólo barra de progreso).

/uninstall Desinstala el paquete.

Opciones de reinicio

/norestart No reinicia cuando se completa la instalación.

/forcerestart Reinicia después de la instalación.

Opciones especiales

/l Enumera los paquetes de actualización y las revisiones de Windows instalados.

/o  Sobrescribe los archivos OEM sin preguntar.

/n  No hace una copia de seguridad de los archivos necesarios para la desinstalación.

/f Obliga a otros programas a cerrarse cuando se apaga el equipo.

/extract  Extrae los archivos sin iniciar la instalación.

Nota Estos parámetros pueden combinarse en un mismo comando. Para mantener la compatibilidad con productos anteriores, esta actualización de seguridad también admite los parámetros de instalación que utilizan las versiones anteriores de la utilidad de instalación. Para obtener más información acerca de los parámetros de instalación admitidos, consulte el artículo de Microsoft Knowledge Base 262841.

Información sobre la implementación

Para instalar la actualización de seguridad sin intervención del usuario, escriba la línea de comandos siguiente en el símbolo del sistema:

 IE6.0sp1-KB889293-Windows-2000-XP-x86-enu /passive /quiet

Para instalar la actualización de seguridad sin necesidad de reiniciar el sistema, escriba la siguiente línea de comandos en el símbolo del sistema:

 IE6.0sp1-KB889293-Windows-2000-XP-x86-enu /norestart

Para obtener más información acerca de cómo implementar esta actualización de seguridad con Software Update Services, visite el sitio Web de Software Update Services.

Para obtener más información acerca de cómo implementar esta actualización con SMS, consulte el artículo 887437 de Microsoft Knowledge Base.

Requisito de reinicio

Debe reiniciar el sistema después de instalar esta actualización de seguridad. No tiene que iniciar sesión como administrador después de reiniciar el equipo para ninguna versión de esta actualización.

Información sobre la eliminación

Para quitar esta actualización, utilice la herramienta Agregar o quitar programas, que se encuentra en el Panel de control. El elemento que hace referencia a esta actualización la presentará como una actualización para Windows, no como una actualización para Internet Explorer. Se trata de un cambio con respecto a anteriores actualizaciones de seguridad acumulativas para Internet Explorer.

Los administradores de sistemas también pueden utilizar la utilidad Spuninst.exe para desinstalar esta actualización de seguridad. La utilidad Spuninst.exe se encuentra en la carpeta Windir%\$NTUninstallKB889293-ie6sp1-20041111.235619$\Spuninst. Esta utilidad admite los siguientes parámetros de instalación:

/?: Muestra la lista de parámetros de instalación.

/u: Usa el modo desatendido.

/f: Obliga a otros programas a cerrarse cuando se apaga el equipo.

/z: No reinicia al terminar la instalación.

/q: Usa el modo silencioso (sin interacción del usuario).

Información sobre archivos

La versión en inglés de esta actualización presenta los atributos de archivo (o posteriores) que se indican en la tabla siguiente. Las fechas y horas de estos archivos se muestran en el horario universal coordinado (UTC). Cuando se consulta la información de archivo, ésta se convierte al horario local. Para averiguar la diferencia entre el horario universal coordinado y el local, utilice la ficha Zona horaria en la herramienta Fecha y hora del Panel de control.

Internet Explorer 6 Service Pack 1 en Windows 2000 y Windows XP:

Nombre de archivoVersiónFechaHoraTamaño

Browseui.dll

6.0.2800.1584

23-ago-2004

02:34

1.025.536

Inseng.dll

6.0.2800.1469

26-ago-2004

17:53

69.632

Mshtml.dll

6.0.2800.1479

25-oct-2004

18:39

2.693.120

Shdocvw.dll

6.0.2800.1606

12-nov-2004

07:20

1.332.224

Shlwapi.dll

6.0.2800.1584

20-ago-2004

22:01

422.912

Urlmon.dll

6.0.2800.1479

25-oct-2004

18:39

450.048

Wininet.dll

6.0.2800.1468

24-ago-2004

03:32

589.312

Internet Explorer 6 Service Pack 1 (64-Bit Edition) en Windows XP:

Nombre de archivoVersiónFechaHoraTamañoCPUCarpeta

Browseui.dll

6.0.2800.1584

22-ago-2004

23:49

2.855.936

IA-64

Ninguna

Inseng.dll

6.0.2800.1469

26-ago-2004

17:53

230.912

IA-64

Ninguna

Mshtml.dll

6.0.2800.1479

25-oct-2004

19:34

9.107.456

IA-64

Ninguna

Shdocvw.dll

6.0.2800.1606

12-nov-2004

07:22

3.651.072

IA-64

Ninguna

Shlwapi.dll

6.0.2800.1584

20-ago-2004

21:52

1.117.184

IA-64

Ninguna

Urlmon.dll

6.0.2800.1479

25-oct-2004

19:33

1.425.408

IA-64

Ninguna

Wininet.dll

6.0.2800.1468

24-ago-2004

01:56

1.798.656

IA-64

Ninguna

Wbrowseui.dll

6.0.2800.1584

23-ago-2004

02:34

1.025.536

x86

WOW

Winseng.dll

6.0.2800.1469

26-ago-2004

17:53

69.632

x86

WOW

Wmshtml.dll

6.0.2800.1479

25-oct-2004

18:39

2.693.120

x86

WOW

Wshdocvw.dll

6.0.2800.1606

12-nov-2004

07:20

1.332.224

x86

WOW

Wshlwapi.dll

6.0.2800.1584

20-ago-2004

22:01

422.912

x86

WOW

Wurlmon.dll

6.0.2800.1479

25-oct-2004

18:39

450.048

x86

WOW

Wwininet.dll

6.0.2800.1468

24-ago-2004

03:32

589.312

x86

WOW

Comprobación de la instalación de la actualización

Microsoft Baseline Security Analyzer

Para comprobar que una actualización de seguridad está instalada en un sistema afectado, puede tratar de utilizar la herramienta Baseline Security Analyzer (MBSA) de Microsoft. Esta herramienta permite a los administradores examinar sistemas remotos y locales para detectar las actualizaciones de seguridad que faltan así como las configuraciones de seguridad incorrectas más comunes. Para obtener más información acerca de MBSA, visite el sitio Web de Microsoft Baseline Security Analyzer.

Comprobación de la versión del archivo

Nota Puesto que existen varias versiones de Microsoft Windows, los pasos que se indican a continuación pueden ser diferentes para la ejecución del procedimiento en su equipo. En tal caso, consulte la documentación del producto para ejecutar los pasos necesarios.

1.

Haga clic en Inicio y, después, en Buscar.

2.

En el panel Resultados de la búsqueda, haga clic en Todos los archivos y carpetas del Asistente para búsqueda.

3.

En el cuadro Todo o parte del nombre de archivo, escriba un nombre de archivo de la tabla de información de archivos correspondiente y, a continuación, haga clic en Buscar.

4.

En la lista de archivos, haga clic con el botón secundario del mouse en un nombre de archivo de la tabla de información de archivos correspondiente y, después, haga clic en Propiedades.

Nota Según la versión del sistema operativo o de los programas instalados, cabe la posibilidad de que algunos de los archivos enumerados en la tabla de información de archivos no estén instalados.

5.

En la ficha Versión, determine la versión del archivo instalado en el equipo por comparación con la versión documentada en la tabla de información de archivos correspondiente.

Nota Los atributos distintos a la versión del archivo pueden cambiar durante la instalación. La comparación de otros atributos de los archivos con los datos de la tabla de información de archivos no constituye un método apropiado para comprobar la instalación de la actualización. Además, en ciertos casos, el nombre de los archivos se puede cambiar durante la instalación. Si no aparece información de la versión o del archivo, recurra a otro de los métodos disponibles para comprobar la instalación de la actualización.

Comprobación de las claves del Registro

También puede comprobar los archivos que ha instalado esta actualización de seguridad mediante la confirmación de la existencia de Installed o del valor de DWORD isInstalled con el valor de datos 1 en las siguientes claves de registro respectivamente.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix\KB889293-ie6sp1-20041111.235619

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{839117ee-2132-4bae-a56a-42b50204c9b9}

Internet Explorer 6 SP1 para Windows NT Server 4.0 Service Pack 6a (todas las versiones), Windows Millennium Edition (Me) y Windows 98 (todas las versiones)

Requisitos previos
Para instalar las versiones para Internet Explorer 6 Service Pack 1 (SP1) de esta actualización, debe ejecutar Internet Explorer 6 SP1 (versión 6.00.2800.1106) en una de las siguientes versiones de Windows:

Microsoft Windows 98

Microsoft Windows 98 Segunda edición (SE)

Microsoft Windows Millennium Edition (Me)

Microsoft Windows NT Server 4.0 Service Pack 6a

Microsoft Windows NT Server 4.0 Terminal Server Edition, Service Pack 6

Nota Las versiones de Windows y de Internet Explorer que no se mencionan en este artículo ya no reciben soporte técnico o no están afectadas. Microsoft recomienda que realice la actualización a una versión admitida de Windows y de Internet Explorer y, a continuación, que instale la actualización adecuada.

Para obtener más información acerca de los ciclos de vida del soporte técnico para los componentes de Windows, visite el sitio Web del Ciclo de vida del soporte técnico de Microsoft.

Para obtener más información acerca de cómo obtener el Service Pack más reciente para Internet Explorer 6, vea el artículo de Microsoft Knowledge Base 328548.

Inclusión en futuros Service Packs:
La actualización para este problema se incluirá en una versión futura de Windows XP.

La actualización de seguridad admite los siguientes parámetros de instalación:

 /Q Especifica el modo silencioso o suprime los mensajes al extraer los archivos.

 /Q:U Especifica el modo silencioso de usuario, que muestra al usuario algunos cuadros de diálogo.

 /Q:A Especifica el modo silencioso de administrador, que no muestra al usuario ningún cuadro de diálogo.

 /T: <ruta de acceso completa> Especifica la carpeta de destino para extraer los archivos.

 /C Extrae los archivos sin instalarlos. Si /T: ruta_de_acceso no se especifica, aparece un mensaje para pedir una carpeta de destino

 /C: <Cmd> Reemplaza el comando de instalación definido por el autor. Especifica la ruta de acceso y el nombre del archivo .inf o .exe de la instalación.

 /R:N Nunca reinicia el equipo después de la instalación.

 /R:I Muestra un mensaje al usuario para reiniciar el equipo si es necesario, excepto cuando se usa con /Q:A.

 /R:A Siempre reinicia el equipo después de la instalación.

 /R:S Reinicia el equipo después de la instalación sin pedir confirmación al usuario.

Nota Estos parámetros no funcionan necesariamente con todas las actualizaciones. Si un parámetro no está disponible, indica que esa funcionalidad se necesita para la correcta instalación de la actualización. Además, no se admite el uso del parámetro /N:V y podría impedir el reinicio del sistema. Si la instalación no se realiza correctamente, debería consultar con el servicio de soporte técnico para saber el motivo.

Para obtener información adicional acerca de los parámetros de instalación admitidos, vea el artículo 197147 de Microsoft Knowledge Base.

Información sobre la implementación

Por ejemplo, para instalar la actualización sin intervención del usuario y sin obligar al sistema a reiniciarse, utilice el siguiente comando en el símbolo del sistema:

IE6.0sp1-KB889293-Windows NT4sp6a-98-ME-x86-ENU.exe /q:a /r:n

Para obtener más información acerca de cómo implementar esta actualización de seguridad con Software Update Services, visite el sitio Web de Software Update Services.

Para obtener más información acerca de cómo implementar esta actualización con SMS, consulte el artículo 887437 de Microsoft Knowledge Base.

Requisito de reinicio

Debe reiniciar el sistema después de instalar esta actualización de seguridad.

Para quitar esta actualización, utilice la herramienta Agregar o quitar programas, que se encuentra en el Panel de control. Haga clic en Internet Explorer 889293 y, a continuación, en Cambiar/Quitar (o haga clic en Agregar o quitar).

Los administradores de sistemas pueden utilizar la utilidad Ieuninst.exe para desinstalar esta actualización. Esta actualización de seguridad instala la utilidad Ieuninst.exe en la carpeta %Windir%. Esta utilidad admite los siguientes parámetros de instalación:

 /?: Muestra la lista de parámetros admitidos

 /z: No reinicia al terminar la instalación.

 /q: Usar el modo silencioso (sin interacción del usuario)

Por ejemplo, para desinstalar esta actualización de forma silenciosa, utilice el siguiente comando:

 c:\windows\ieuninst /q c:\windows\inf\q889293.inf

Nota En este comando se supone que Windows está instalado en la carpeta C:\Windows.

Información sobre archivos

La versión en inglés de esta actualización presenta los atributos de archivo (o posteriores) que se indican en la tabla siguiente. Las fechas y horas de estos archivos se muestran en el horario universal coordinado (UTC). Cuando se consulta la información de archivo, ésta se convierte al horario local. Para averiguar la diferencia entre el horario universal coordinado y el local, utilice la ficha Zona horaria en la herramienta Fecha y hora del Panel de control.

Internet Explorer 6 Service Pack 1 en Windows 98, Windows 98 SE, Windows Me y Windows NT:

Nombre de archivoVersiónFechaHoraTamaño

Browseui.dll

6.0.2800.1584

23-ago-2004

02:34

1.025.536

Inseng.dll

6.0.2800.1469

26-ago-2004

17:53

69.632

Mshtml.dll

6.0.2800.1479

25-oct-2004

18:39

2.693.120

Shdocvw.dll

6.0.2800.1606

12-nov-2004

07:20

1.332.224

Shlwapi.dll

6.0.2800.1584

20-ago-2004

22:01

422.912

Urlmon.dll

6.0.2800.1479

25-oct-2004

18:39

450.048

Wininet.dll

6.0.2800.1468

24-ago-2004

03:32

589.312

Comprobación de la instalación de la actualización

Microsoft Baseline Security Analyzer

Para comprobar que una actualización de seguridad está instalada en un sistema afectado, puede tratar de utilizar la herramienta Baseline Security Analyzer (MBSA) de Microsoft. Esta herramienta permite a los administradores examinar sistemas remotos y locales para detectar las actualizaciones de seguridad que faltan así como las configuraciones de seguridad incorrectas más comunes. Para obtener más información acerca de MBSA, visite el sitio Web de Microsoft Baseline Security Analyzer.

Comprobación de la versión del archivo

Nota Puesto que existen varias versiones de Microsoft Windows, los pasos que se indican a continuación pueden ser diferentes para la ejecución del procedimiento en su equipo. En tal caso, consulte la documentación del producto para ejecutar los pasos necesarios.

1.

Haga clic en Inicio y, después, en Buscar.

2.

En el panel Resultados de la búsqueda, haga clic en Todos los archivos y carpetas del Asistente para búsqueda.

3.

En el cuadro Todo o parte del nombre de archivo, escriba un nombre de archivo de la tabla de información de archivos correspondiente y, a continuación, haga clic en Buscar.

4.

En la lista de archivos, haga clic con el botón secundario del mouse en un nombre de archivo de la tabla de información de archivos correspondiente y, después, haga clic en Propiedades.

Nota Según la versión del sistema operativo o de los programas instalados, cabe la posibilidad de que algunos de los archivos enumerados en la tabla de información de archivos no estén instalados.

5.

En la ficha Versión, determine la versión del archivo instalado en el equipo por comparación con la versión documentada en la tabla de información de archivos correspondiente.

Nota Los atributos distintos a la versión del archivo pueden cambiar durante la instalación. La comparación de otros atributos de los archivos con los datos de la tabla de información de archivos no constituye un método apropiado para comprobar la instalación de la actualización. Además, en ciertos casos, el nombre de los archivos se puede cambiar durante la instalación. Si no aparece información de la versión o del archivo, recurra a otro de los métodos disponibles para comprobar la instalación de la actualización.

Comprobación de las claves del Registro

También puede comprobar los archivos que ha instalado esta actualización de seguridad mediante la confirmación de la existencia del valor DWORD Installed con el valor de datos 1 en la siguiente clave del Registro.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{839117ee-2132-4bae-a56a-42b50204c9b9}

Comprobación de la versión del programa

Confirme que en el campo Actualizar versiones del cuadro de diálogo Acerca de Internet Explorer aparece Q889293.

Obtención de otras actualizaciones de seguridad:

Las actualizaciones para otros problemas de seguridad están disponibles en las ubicaciones siguientes:

Hay actualizaciones de seguridad disponibles en el Centro de descarga de Microsoft:si realiza una búsqueda de las palabras clave “revisión seguridad” (security patch) podrá encontrarlas fácilmente.

Hay disponibles actualizaciones para las plataformas de usuarios en el sitio Web de Windows Update.

Soporte técnico:

Los clientes de Estados Unidos y Canadá pueden recibir soporte técnico de los Servicios de soporte técnico de Microsoft en 1-866-PCSAFETY. Las llamadas de soporte técnico relacionadas con las actualizaciones de seguridad son gratuitas.

Los clientes internacionales pueden recibir soporte técnico en las subsidiarias de Microsoft de sus países. Las llamadas de soporte técnico relacionadas con las actualizaciones de seguridad son gratuitas. Para obtener más información acerca de cómo ponerse en contacto con Microsoft en relación con problemas de soporte técnico, visite el sitio Web de soporte técnico internacional de Microsoft.

Recursos de seguridad:

El sitio Web Microsoft TechNet Seguridad proporciona información adicional acerca de la seguridad de los productos de Microsoft.

Microsoft Software Update Services

Microsoft Baseline Security Analyzer (MBSA)

Windows Update 

Catálogo de Windows Update: Para obtener más información acerca del Catálogo de Windows Update, consulte el artículo 323166 de Microsoft Knowledge Base.

Office Update 

Software Update Services:

Software Update Services (SUS) permite a los administradores implementar con rapidez y confiabilidad las actualizaciones críticas y de seguridad más recientes en servidores basados en Windows 2000 y Windows Server 2003, y en sistemas de escritorio donde se ejecute Windows 2000 Professional o Windows XP Professional.

Para obtener más información acerca de cómo implementar esta actualización de seguridad con Software Update Services, visite el sitio Web de Software Update Services.

Systems Management Server:

Microsoft Systems Management Server (SMS) ofrece una solución empresarial altamente configurable para la administración de las actualizaciones. Mediante SMS, los administradores pueden identificar los sistemas basados en Windows que necesitan actualizaciones de seguridad, así como realizar la implementación controlada de las actualizaciones en la empresa con una repercusión mínima para los usuarios finales. Para obtener información acerca de cómo pueden utilizar SMS 2003 los administradores para implementar actualizaciones de seguridad, visite el sitio Web de administración de revisiones de seguridad de SMS 2003. Los usuarios de SMS 2.0 también pueden usar Software Updates Service Feature Pack como ayuda para la implementación de actualizaciones de seguridad. Para obtener más información acerca de SMS, visite el sitio Web de SMS.

Nota SMS utiliza las herramientas Microsoft Baseline Security Analyzer y Microsoft Office Detection Tool para proporcionar un amplio soporte técnico en la detección e implementación de las actualizaciones indicadas en los boletines de seguridad. Puede que estas herramientas no detecten algunas actualizaciones de software. Los administradores pueden usar las prestaciones de inventario de SMS en estos casos para concretar qué actualizaciones se deben aplicar en cada sistema. Para obtener más información acerca de este procedimiento, visite el siguiente sitio Web. Algunas actualizaciones de seguridad pueden requerir derechos administrativos y que se reinicie el sistema. Los administradores pueden usar la utilidad Elevated Rights Deployment Tool (disponible en SMS 2003 Administration Feature Pack y en SMS 2.0 Administration Feature Pack) para instalar estas actualizaciones.

Renuncia:

La información proporcionada en Microsoft Knowledge Base se suministra "tal cual", sin garantía de ningún tipo. Microsoft renuncia al otorgamiento de toda garantía, tanto expresa como implícita, incluidas las garantías de comerciabilidad e idoneidad para un determinado fin. Ni Microsoft Corporation ni sus proveedores se responsabilizarán en ningún caso de daños directos, indirectos, incidentales, consecuenciales, pérdida de beneficios o daños especiales, aun en el supuesto de que se hubiera informado a Microsoft Corporation o a sus proveedores de la posibilidad de dichos daños. Algunos estados de Estados Unidos no permiten la exclusión o limitación de responsabilidad por daños consecuenciales o incidentales, y, por tanto, la limitación anterior puede no ser aplicable en su caso.

Revisiones: 

V1.0 (1 de diciembre de 2004): Publicación del boletín



©2014 Microsoft Corporation. Todos los derechos reservados. Póngase en contacto con nosotros |Aviso Legal |Marcas registradas |Privacidad
Microsoft