Recomenda-se usar a versão mais recente do software. A nova versão trata de alguns problemas que precisam ser solucionados e possui novos recursos.

  • Se você fez o download do cliente Mail for Exchange, isso será possível. Entretanto, não é recomendado fazer o downgrade para um versão anterior. Além disso, a Nokia não fornece softwares mais antigos; ela fornece somente a versão atual.
  • Se o aparelho (por exemplo, E75, E55) usar o cliente multi-protocolo (o cliente que está integrado no firmware), isso não será possível. Os clientes multi-protocolo pré-instalados só podem ser atualizados no firmware.