Linking and embedding

Cutting information from one document and pasting it into another is a good way of reusing information. When you paste information into a document, the information that you paste becomes part of the second document. If you make changes to the information in the original document, those changes will not be reflected in the second document.

For Windows-based programs that support drag-and-drop functions, you can use linking or embedding to transfer information from one document to another document, even if that document is in a different program.

Linking means inserting information that retains a connection to the information stored in the original file. Linking keeps the inserted information up-to-date by refreshing it when there is a change to the original document. To link selected information, use the Copy and Paste Special commands on the Edit menu. To link a file into your document, use the Object command on the Insert menu. For example, if you want to use WordPad to create text that you can reuse in other documents, you can use the Object command on the Insert menu to insert the text into your document as a linked WordPad file. Then, whenever you make changes to the text in the WordPad file, those changes automatically appear in any other documents that contain a link to that WordPad file. Some programs do not support linking.

Embedding means inserting information (such as text or a graphic) into a document in a different program. The embedded information, or object, becomes part of the new document. Changes you make to the original document will not be reflected in the new document. To edit an embedded object, double-click it; the program in which the object was created opens. In order to edit an embedded object, the program in which the object was created (or another program capable of editing the object) must be installed on your computer. When you finish editing the object and return to your document, the document reflects all of the changes you've made. To embed selected information, use the Copy and Paste commands on the Edit menu.

Use linking when you want the information to be updated dynamically as the data in the source file changes. Use embedding when you want to edit the information separately from the source file or if you think the source file will not be available.

Link information between documents

Embed information in another document

Embed or link an object into WordPad



© 2014 Microsoft Corporation. All rights reserved. Contact Us |Terms of Use |Trademarks |Privacy Statement