適用於 Server Core 的 Microsoft .NET Framework 4 (獨立安裝程式)

選取語言:
Microsoft .NET Framework 4 Server Core 安裝程式套件會下載需要的 .NET Framework 4 元件,以便在 Windows Server 2008 R2 SP1 (含) 以上版本執行,做為伺服器核心角色安裝。
  • 版本:

    4

    File Name:

    dotNetFx40_Full_x86_x64_SC.exe

    發佈日期:

    2011/3/1

    File Size:

    48.1 MB

      Microsoft .NET Framework 4 Server Core 下載檔案會在 Windows 2008 R2 SP1 Server Core 上安裝完整的 .NET Framework 4。 這個下載要求必須安裝 Windows 2008 R2 SP1。 當您在 Server Core 上執行 .NET Framework 4 應用程式時,將只有 Server Core 功能可以運作,而且 Server Core 不支援如 Windows Presentation Foundation (WPF) 和 ClickOnce 部署等用戶端應用程式功能。

      若要進一步暸解 .NET Framework 4,請參閱 .NET Framework 4 的新功能,若要安裝在其他作業系統上,請造訪 .NET Framework 4 下載網站。 這個版本中 ASP.NET 的功能包含支援多目標、擴展允許的 URL 範圍、Web 組態檔重整、WebForm 增強功能等。 如需 ASP.NET 增強功能的完整清單,請移到這裡。 Windows Communication Foundation (WCF) 的改進功能,例如支援工作流程服務,以啟用具有通訊活動和相互關聯支援的工作流程程式。 此外,.NET Framework 4 也提供新的 WCF 功能,例如服務探索、路由服務、REST 支援、診斷和效能。 如需 WCF 增強功能的完整清單,請移到這裡

      許多客戶曾經詢問過 PowerShell 是否將使用 Server Core 上的 .NET Framework 4 支援。 安裝 .NET Framework 4 之後,PowerShell 2.0 會繼續在 Windows 2008 R2 SP1 Server Core 上運作 (利用已安裝的 .NET Framework 3.5.SP1)。 PowerShell 2.0 不會使用 .NET Framework 4,因此,不支援撰寫 .NET Framework 4 Cmdlet,也不支援在 Windows 2008 R2 Server Core 上執行。

      我們建議您針對為 Server Core 建置的 .NET Framework 應用程式進行測試。 某些 .NET Framework 功能無法在 Server Core 上運作,特別是如果該功能相依於 Server Core 上未安裝的作業系統檔案時。 只有 Windows 2008 R2 SP1 Server Core 支援 .Net Framework 4 Server Core 套件。 如果您嘗試在非 Server Core 電腦上使用,將無法正確安裝。

  • 支援的作業系統

    Windows Server 2008 R2 SP1

        • Windows Server 2008 R2 SP1 Server Core (含) 以後版本
      • 支援的架構:
        • x64
      • 硬體需求:
        • 建議最低規格:單一處理器,配備 1.4 GHz (x64 處理器) 或配備 512 MB (含) 以上 RAM 的 1.3GHz (雙核心)
        • 磁碟空間最低需求:2 GB (作業系統需要 32 GB 以上)
      1. 重要事項:請確定您的電腦已安裝最新的 Windows Service Pack 和重大更新。 若要尋找安全性更新,請造訪 Windows Update
      2. 如果要安裝在 Windows 2008 Server R2 Server Core 上,您必須先安裝 Windows 2008 Server R2 SP1 並依照下面指示執行,然後才能安裝 .NET Framework 4
        • 開啟 WoW64:啟動 /w ocsetup ServerCore-WOW64
        • 開啟 .NET 2.0 層:啟動 /w ocsetup NetFx2-ServerCore
        • 開啟 WoW64 的 .NET 2.0 層:啟動 /w ocsetup NetFx2-ServerCore-WOW64
      3. 在這個網頁上,找到並按一下 [下載] 按鈕,開始下載。
      4. 若要將下載的檔案儲存到電腦以便稍後進行安裝,請按一下 [儲存]。
      5. 若要取消下載,請按一下 [取消]。
      6. 將 .NET Framework 4 安裝在 Windows 2008 R2 SP1 Server Core 之後,強烈建議您安裝 Windows Update 上提供的重大 .NET Framework 4 更新。

    • 伺服器安裝的額外需求

      如果您必須執行伺服器安裝,則除了基本的需求之外,您的電腦還必須安裝下列軟體:

      • 網際網路資訊服務 (IIS) version 6.0 (含) 以後版本。 若要存取 ASP.NET 的各項功能,請務必在安裝 .NET Framework 之前先安裝 IIS,並且應該安裝最新版本的安全性更新。 只有 Windows XP Professional、Windows Server 2003、Windows Server 2008 和 Windows Server 2008 R2 能夠支援 ASP.NET。
      • (建議) Microsoft Data Access Components 2.8 (含) 以後版本


      注意:大部分的使用者並不需要執行伺服器安裝。 如果您不確定是否要執行伺服器安裝,則只要執行基本安裝即可。


      .NET Framework 4 讀我檔案