{"id":112701,"date":"2022-04-26T09:00:00","date_gmt":"2022-04-26T16:00:00","guid":{"rendered":""},"modified":"2025-06-20T02:28:49","modified_gmt":"2025-06-20T09:28:49","slug":"microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn","status":"publish","type":"post","link":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/","title":{"rendered":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn"},"content":{"rendered":"\n<p class=\"wp-block-paragraph\">Microsoft has discovered several vulnerabilities, collectively referred to as Nimbuspwn, that could allow an attacker to elevate privileges to root on many Linux desktop endpoints. The vulnerabilities can be chained together to gain root privileges on Linux systems, allowing attackers to deploy payloads, like a root backdoor, and perform other malicious actions via arbitrary root code execution. Moreover, the Nimbuspwn vulnerabilities could potentially be leveraged as a vector for root access by more sophisticated threats, such as malware or ransomware, to achieve greater impact on vulnerable devices.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">We discovered the vulnerabilities by listening to messages on the System Bus while performing code reviews and dynamic analysis on services that run as root, noticing an odd pattern in a systemd unit called <em>networkd-dispatcher<\/em>. Reviewing the code flow for <em>networkd-dispatcher<\/em> revealed multiple security concerns, including directory traversal, symlink race, and time-of-check-time-of-use race condition issues, which could be leveraged to elevate privileges and deploy malware or carry out other malicious activities. We shared these vulnerabilities with the relevant maintainers through <a href=\"https:\/\/www.microsoft.com\/msrc\/cvd?rtc=1\">Coordinated Vulnerability Disclosure<\/a> (CVD) via <a href=\"https:\/\/www.microsoft.com\/msrc\/msvr\">Microsoft Security Vulnerability Research<\/a> (MSVR). Fixes for these vulnerabilities, now identified as <a href=\"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2022-29799\">CVE-2022-29799<\/a> and <a href=\"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2022-29800\">CVE-2022-29800<\/a>, have been successfully deployed by the maintainer of the <em>networkd-dispatcher<\/em>, Clayton Craft. We wish to thank Clayton for his professionalism and collaboration in resolving those issues. Users of <em>networkd-dispatcher<\/em> are encouraged to update their instances.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">As organizational environments continue to rely on a diverse range of devices and systems, they require comprehensive solutions that provide cross-platform protection and a holistic view of their security posture to mitigate threats, such as Nimbuspwn. The growing number of vulnerabilities on Linux environments emphasize the need for strong monitoring of the platform\u2019s operating system and its components. Microsoft Defender for Endpoint enables organizations to gain this necessary visibility and detect such threats on <a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/microsoft-defender-endpoint-linux?view=o365-worldwide\">Linux devices<\/a>, allowing organizations to detect, manage, respond, and remediate vulnerabilities and threats across different platforms, including Windows, Linux, Mac, iOS, and Android.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">In this blog post, we will share some information about the affected components and examine the vulnerabilities we uncovered. Detailing how our cross-domain visibility helps us uncover new and unknown threats to continually improve security, we are also sharing details from our research with the larger security community to underscore the importance of securing platforms and devices.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"background-d-bus\">Background \u2013 D-Bus<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\"><a href=\"https:\/\/en.wikipedia.org\/wiki\/D-Bus\">D-Bus<\/a> (short for \u201cDesktop-Bus\u201d) is an inter-process communication channel (IPC) mechanism developed by the <a href=\"https:\/\/www.freedesktop.org\/\">freedesktop.org<\/a> project. D-Bus is a software-bus and allows processes on the same endpoint to communicate by transmitting messages and responding to them. D-Bus supports two main ways of communicating:<\/p>\n\n\n\n<ol style=\"list-style-type:lower-alpha\" class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Methods \u2013 used for request-response communications.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Signals \u2013 used for publish\/subscribe communications.<\/li>\n<\/ol>\n\n\n\n<p class=\"wp-block-paragraph\">An example of D-Bus usage would be receiving a video chat by a popular video conferencing app\u2013once a video is established, the video conferencing app could send a D-bus signal publishing that a call has started. Apps listening to that message could respond appropriately\u2013for example, mute their audio.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">There are many D-Bus components shipped by default on popular Linux desktop environments. Since those components run at different privileges and respond to messages, D-Bus components are an attractive target for attackers. Indeed, there have been interesting vulnerabilities in the past related to buggy D-Bus services, including <a href=\"https:\/\/unit42.paloaltonetworks.com\/usbcreator-d-bus-privilege-escalation-in-ubuntu-desktop\/\">USBCreator Elevation of Privilege<\/a>, <a href=\"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=1892437\">Blueman Elevation of Privilege by command injection<\/a>, and other similar scenarios.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">D-Bus exposes a global <em>System Bus<\/em> and a per-session <em>Session Bus<\/em>. From an attacker\u2019s perspective, the System Bus is more attractive since it will commonly have services that run as root listening to it.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"d-bus-name-ownership\">D-Bus name ownership<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">When connecting to the D-Bus, components are assigned with a unique identifier, which mitigates against attacks abusing PID-recycling. The unique identifier starts with a colon and has numbers in it separated by dots, such as \u201c:1.337\u201d. Components can use the D-Bus API to own identifiable names such as \u201corg.freedesktop.Avahi\u201d or \u201ccom.ubuntu.SystemService\u201d. For D-Bus to allow such ownership, the requesting process context must be allowed under the D-Bus configuration files. Those configuration files are <a href=\"https:\/\/dbus.freedesktop.org\/doc\/dbus-daemon.1.html\">well documented<\/a> and maintained under <em>\/usr\/local\/share\/dbus-1\/system.conf<\/em> and <em>\/usr\/local\/share\/dbus-1\/session.conf<\/em> (on some systems under <em>\/usr\/local\/dbus-1<\/em> directly). Specifically, the default <em>system.conf<\/em> does not allow ownership unless specified otherwise in other included configuration files (commonly under <em>\/etc\/dbus-1\/system.d<\/em>).<\/p>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"148\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-1-Different-ownership-policies-for-the-System-Bus-and-the-Session-Bus.png\" alt=\"Figure 1 displays different ownership policies for the System Bus and the Session Bus; \" class=\"wp-image-112704\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-1-Different-ownership-policies-for-the-System-Bus-and-the-Session-Bus.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-1-Different-ownership-policies-for-the-System-Bus-and-the-Session-Bus-300x56.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-1-Different-ownership-policies-for-the-System-Bus-and-the-Session-Bus-768x142.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 1: Different ownership policies for the System Bus and the Session Bus<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Additionally, if the name requested already exists\u2013the request will not be granted until the owning process releases the name.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"vulnerability-hunting\">Vulnerability hunting<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\">Our team has started enumerating services that run as root and listen to messages on the System Bus, performing both code reviews and dynamic analysis. We have reported two information leak issues as a result:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/blueman-project\/blueman\/security\/advisories\/GHSA-3r9p-m5c8-8mw8\">Directory Info Disclosure in Blueman<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/access.redhat.com\/security\/cve\/cve-2022-0987\">Directory Info Disclosure in PackageKit (CVE-2022-0987)<\/a><\/li>\n<\/ol>\n\n\n\n<p class=\"wp-block-paragraph\">While these are interesting, their severity is low \u2013 an attacker can list files under directories that require high permissions to list files under. Then we started noticing interesting patterns in a <a href=\"https:\/\/en.wikipedia.org\/wiki\/Systemd\">systemd unit<\/a> called <em>networkd-dispatcher<\/em>. The goal of <em>networkd-dispatcher<\/em> is to dispatch network status changes and optionally perform different scripts based on the new status. Interestingly, it runs on boot as root:<\/p>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"44\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-2-networkd-dispatcher-running-as-root.png\" alt=\"Figure 2 displays networkd-dispatcher running as root.\" class=\"wp-image-112707\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-2-networkd-dispatcher-running-as-root.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-2-networkd-dispatcher-running-as-root-300x17.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-2-networkd-dispatcher-running-as-root-768x42.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 2: <em>networkd-dispatcher<\/em> running as root<\/figcaption><\/figure>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"code-flow-for-networkd-dispatcher\">Code flow for <em>networkd-dispatcher<\/em><\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">Upon examination of the <em>networkd-dispatcher<\/em> <a href=\"https:\/\/gitlab.com\/craftyguy\/networkd-dispatcher\">source code<\/a>, we noticed an interesting flow:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">The <em>register<\/em> function registers a new signal receiver for the service \u201c<em>org.freedesktop.network1<\/em>\u201d on the System Bus, for the signal name \u201d<em>PropertiesChanged<\/em>\u201d.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">The \u201d<em>_receive_signal<\/em>\u201c signal handler will perform some basic checks on the object type being sent, concludes the changed network interface based on the object path being sent, and then concludes its new states\u2013\u201c<em>OperationalState<\/em>\u201d and \u201c<em>AdministrativeState<\/em>\u201d\u2013each fetched from the data. For any of those states\u2013if they aren\u2019t empty\u2013the \u201c<em>handle_state<\/em>\u201d method will get invoked.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">The \u201c<em>handle_state<\/em>\u201d method simply invokes \u201c<em>_handle_one_state<\/em>\u201c for each of those two states.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">\u201c<em>_handle_one_state<\/em>\u201d validates the state isn\u2019t empty and checks if it\u2019s different than the previous state. If it is, it will update the new state and invoke the \u201c<em>_run_hooks_for_state<\/em>\u201d method, which is responsible of discovering and running the scripts for the new state.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">\u201c<em>_run_hooks_for_state<\/em>\u201d implements the following logic:\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Discovers the script list by invoking the \u201c<em>get_script_list<\/em>\u201d method (which gets the new state as a string). This method simply calls \u201c<em>scripts_in_path<\/em>\u201d which is intended to return all the files under \u201c<em>\/etc\/networkd-dispatcher\/&lt;state>.d<\/em>\u201d that are owned by the root user and the root group, and are executable.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Sorts the script list.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Runs each script with <a href=\"https:\/\/docs.python.org\/3\/library\/subprocess.html#subprocess.Popen\">subprocess.Popen<\/a> while supplying custom environment variables.<\/li>\n<\/ul>\n<\/li>\n<\/ol>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"427\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-3-_run_hooks_for_state-source-code-some-parts-omitted-for-brevity.png\" alt=\"Figure 3 displays a snippet of the _run_hooks_for_state source code.\" class=\"wp-image-112710\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-3-_run_hooks_for_state-source-code-some-parts-omitted-for-brevity.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-3-_run_hooks_for_state-source-code-some-parts-omitted-for-brevity-300x160.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-3-_run_hooks_for_state-source-code-some-parts-omitted-for-brevity-768x410.png 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-3-_run_hooks_for_state-source-code-some-parts-omitted-for-brevity-389x209.png 389w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 3: _run_hooks_for_state source code &#8211; some parts omitted for brevity<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Step 5 has multiple security issues:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/en.wikipedia.org\/wiki\/Directory_traversal_attack\"><em>Directory traversal <\/em><\/a><em>(<a href=\"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2022-29799\">CVE-2022-29799<\/a>)<\/em>: none of the functions in the flow sanitize the <em>OperationalState<\/em> or the <em>AdministrativeState<\/em>. Since the states are used to build the script path, it is possible that a state would contain directory traversal patterns (e.g. \u201c<em>..\/..\/<\/em>\u201d) to escape from the \u201c<em>\/etc\/networkd-dispatcher<\/em>\u201d base directory.<\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/en.wikipedia.org\/wiki\/Symlink_race\"><em>Symlink race<\/em><\/a>: both the script discovery and <em>subprocess.Popen<\/em> follow symbolic links.<\/li>\n\n\n\n<li class=\"wp-block-list-item\"><em>Time-of-check-time-of-use (<\/em><a href=\"https:\/\/en.wikipedia.org\/wiki\/Time-of-check_to_time-of-use\"><em>TOCTOU<\/em><\/a><em>) race condition (<a href=\"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2022-29800\">CVE-2022-29800<\/a>)<\/em>: there is a certain time between the scripts being discovered and them being run. An attacker can abuse this vulnerability to replace scripts that <em>networkd-dispatcher<\/em> believes to be owned by root to ones that are not.<\/li>\n<\/ol>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"386\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/6267e7bcdaac2-6267e7bcdaac3Figure-4-Building-the-script-list-in-the-scripts_in_path-method-including-the-vulnerable-code-with-subdir-poisoned..png.png\" alt=\"Figure 4 displays building the script list in the &quot;scripts_in_path&quot; method, including the vulnerable code with &quot;subdir&quot; poisoned, which is highlighted with a red box over the text reading &quot;os.path.join(one path, subdir, filename)&quot;.\" class=\"wp-image-112713\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/6267e7bcdaac2-6267e7bcdaac3Figure-4-Building-the-script-list-in-the-scripts_in_path-method-including-the-vulnerable-code-with-subdir-poisoned..png.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/6267e7bcdaac2-6267e7bcdaac3Figure-4-Building-the-script-list-in-the-scripts_in_path-method-including-the-vulnerable-code-with-subdir-poisoned..png-300x145.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/6267e7bcdaac2-6267e7bcdaac3Figure-4-Building-the-script-list-in-the-scripts_in_path-method-including-the-vulnerable-code-with-subdir-poisoned..png-768x371.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 4: Building the script list in the &#8220;scripts_in_path&#8221; method, including the vulnerable code with \u201csubdir\u201d poisoned.<\/figcaption><\/figure>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"exploitation\">Exploitation<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\">Let us assume an adversary has a malicious D-Bus component that can send an arbitrary signal. An attacker can therefore do the following:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Prepare a directory \u201d<em>\/tmp\/nimbuspwn<\/em>\u201d and plant a symlink \u201d<em>\/tmp\/nimbuspwn\/poc.d<\/em>\u201c to point to \u201c<em>\/sbin<\/em>\u201d. The <em>\u201c\/sbin\u201d <\/em>directory was chosen specifically because it has many executables owned by root that do not block if run without additional arguments. This will abuse the <em>symlink race<\/em> issue we mentioned earlier.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">For every executable filename under \u201c<em>\/sbin<\/em>\u201d owned by root, plant the same filename under \u201c<em>\/tmp\/nimbuspwn<\/em>\u201d. For example, if \u201c<em>\/sbin\/vgs<\/em>\u201d is executable and owned by root, plant an executable file \u201c<em>\/tmp\/nimbuspwn\/vgs<\/em>\u201d with the desired payload. This will help the attacker win the race condition imposed by the <em>TOCTOU<\/em> vulnerability.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Send a signal with the <em>OperationalState<\/em> <em>\u201c..\/..\/..\/tmp\/nimbuspwn\/poc\u201d<\/em>. This abuses the <em>directory traversal<\/em> vulnerability and escapes the script directory.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">The <em>networkd-dispatcher<\/em> signal handler kicks in and builds the script list from the directory <em>\u201c\/etc\/networkd-dispatcher\/..\/..\/..\/tmp\/nimbuspwn\/poc.d\u201d<\/em>, which is really the symlink (<em>\u201c\/tmp\/nimbuspwn\/poc.d\u201d<\/em>), which points to <em>\u201c\/sbin\u201d<\/em>. Therefore, it creates a list composed of many executables owned by root.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Quickly change the symlink \u201c<em>\/tmp\/nimbuspwn\/poc.d\u201d<\/em> to point to \u201c<em>\/tmp\/nimbuspwn<\/em>\u201d. This abuses the <em>TOCTOU race condition<\/em> vulnerability\u2013the script path changes without <em>networkd-dispatcher<\/em> being aware.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">The dispatcher starts running files that were initially under \u201c<em>\/sbin<\/em>\u201d but in truth under the \u201c<em>\/tmp\/nimbuspwn<\/em>\u201d directory. Since the dispatcher \u201cbelieves\u201d those files are owned by root, it executes them blindly with subprocess.Popen as root. Therefore, our attacker has successfully exploited the vulnerability.<\/li>\n<\/ol>\n\n\n\n<p class=\"wp-block-paragraph\">Note that to win the <em>TOCTOU<\/em><em> race condition<\/em> with high probability, we plant many files that can potentially run. Our experiments show three attempts were enough to win the <em>TOCTOU<\/em><em> race condition<\/em>.<\/p>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"996\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-5-Flow-chart-of-the-attack-in-three-stages.png\" alt=\"Figure 5 displays a flow-chart of the attack in 3 stages. The first 3 steps are depicted in the top image, displaying the attacker's initial steps. The 4th step is depicted in the middle image, displaying how networkd-dispatcher processes the attacker's modifications. Steps 5 and 6 are depicted in the final image, displaying how the attacker abuses the TOCTOU race condition flaw so that the dispatcher ultimately permits the Nimbuspwn exploit. \" class=\"wp-image-112716\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-5-Flow-chart-of-the-attack-in-three-stages.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-5-Flow-chart-of-the-attack-in-three-stages-241x300.png 241w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-5-Flow-chart-of-the-attack-in-three-stages-768x956.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 5: Flow-chart of the attack in three stages<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Since we do not wish to run the exploit every time we want to run as root, the payload that we ended up implementing leaves a root backdoor as such:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Copies <em>\/bin\/sh<\/em> to <em>\/tmp\/sh<\/em>.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Turns the new <em>\/tmp\/sh<\/em> it into a <a href=\"https:\/\/attack.mitre.org\/techniques\/T1548\/001\/\">Set-UID (SUID) binary<\/a>.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Run <em>\/tmp\/sh -p<\/em>. The \u201c<em>-p<\/em>\u201d flag is necessary since modern shells drop privileges by design.<\/li>\n<\/ol>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"owning-the-bus-name\">Owning the bus name<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">The astute reader will notice that the entire exploit elevates privileges assuming our exploit code can own the \u201c<em>org.freedesktop.network1<\/em>\u201d bus name. While this sounds non-trivial, we have found several environments where this happens. Specifically:<\/p>\n\n\n\n<ol class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">On many environments (e.g. Linux Mint) the service <em>systemd-networkd<\/em> that normally owns the \u201c<em>org.freedesktop.network1<\/em>\u201d bus name does not start at boot by default.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Using <a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/advanced-hunting-overview?view=o365-worldwide\">advanced hunting in Microsoft Defender for Endpoint<\/a> we were able to spot several processes running as the <em>systemd-network<\/em> user (which is permitted to own the bus name we require) running arbitrary code from world-writable locations. These include several scenarios on specific environments that allow running arbitrary code as <em>systemd-network<\/em>, such as running a script from a world-writable directory. We attribute some of those scenarios to customer misconfigurations.<\/li>\n<\/ol>\n\n\n\n<p class=\"wp-block-paragraph\">The query we used can also be run by Microsoft Defender for Endpoint customers:<\/p>\n\n\n\n<pre class=\"wp-block-preformatted\">DeviceProcessEvents\n| where Timestamp &gt; ago(5d)\n    and AccountName == \"systemd-network\"\n    and isnotempty(InitiatingProcessAccountName)\n    and isnotempty(FileName)\n| project DeviceId, FileName, FolderPath, ProcessCommandLine\n<\/pre>\n\n\n\n<p class=\"wp-block-paragraph\">We were therefore able to exploit these scenarios and implement our own exploit:<\/p>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"598\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race.png\" alt=\"Figure 6 displays our successfully implemented exploit after winning the TOCTOU race condition. The title reads &quot;Nimbuspwn: networkd-dispatcher Linux EoP by Jonathan Bar Or ('JBO')&quot;. The processes are then displayed, reading top to bottom: &quot;Attempting to own dbus name org.freedesktop.network1&quot;, &quot;Validating name patterns&quot;, &quot;Planting base directory&quot;, &quot;Planting symlink&quot;, &quot;Planting payload&quot;, it then takes four attempts to &quot;win the (TOCTOU) race&quot; condition before stating &quot;Great, we now have a root backdoor. Hurray! Enjoy your root privileges&quot;. \" class=\"wp-image-112719\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race-300x224.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race-768x574.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 6: Our exploit implemented and winning the TOCTOU race<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">While capable of running any arbitrary script as root, our exploit copies <em>\/bin\/sh<\/em> to the <em>\/tmp<\/em> directory, sets <em>\/tmp\/sh<\/em> as a <a href=\"https:\/\/attack.mitre.org\/techniques\/T1548\/001\/\">Set-UID (SUID) executable<\/a>, and then invokes \u201c<em>\/tmp\/sh -p<\/em>\u201d. Note that the \u201c<em>-p<\/em>\u201d flag is necessary to force the shell to not drop privileges.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"hardening-device-security-and-detection-strategy\">Hardening device security and detection strategy<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\">Despite the evolving threat landscape regularly delivering new threats, techniques, and attack capabilities, adversaries continue to focus on identifying and taking advantage of unpatched vulnerabilities and misconfigurations as a vector to access systems, networks, and sensitive information for malicious purposes. This constant bombardment of attacks spanning a wide range of platforms, devices, and other domains emphasizes the need for a comprehensive and proactive vulnerability management approach that can further identify and mitigate even previously unknown exploits and issues.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft\u2019s <a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/next-gen-threat-and-vuln-mgt?view=o365-worldwide\">threat and vulnerability management<\/a> capabilities help organizations monitor their overall security posture, providing real-time insights into risk with continuous vulnerability discovery, contextualized intelligent prioritization, and seamless one-click flaw remediation. Leveraging our research into the Nimbuspwn vulnerabilities to improve solutions, our threat and vulnerability management already covers CVE-2022-29799 and CVE-2022-29800 and indicates such vulnerable devices in the threat and vulnerability module in <a href=\"https:\/\/www.microsoft.com\/security\/business\/threat-protection\/endpoint-defender?rtc=1\">Microsoft Defender for Endpoint<\/a>.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">To address the specific vulnerabilities at play, Microsoft Defender for Endpoint\u2019s <a href=\"https:\/\/docs.microsoft.com\/microsoft-365\/security\/defender-endpoint\/overview-endpoint-detection-response?view=o365-worldwide\">endpoint detection and response (EDR)<\/a> capabilities detect the directory traversal attack required to leverage Nimbuspwn. Additionally, the Microsoft Defender for Endpoint detection team has a generic detection for suspicious Set-UID process invocations, which detected our exploit without prior knowledge.<\/p>\n\n\n\n<figure class=\"wp-block-image size-full\"><img loading=\"lazy\" decoding=\"async\" width=\"800\" height=\"426\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-7-Microsoft-Defender-for-Endpoint-detecting-a-suspicious-SUID-process-used-in-our-exploit.png\" alt=\"Figure 7 displays Microsoft Defender for Endpoint detecting a suspicious SUID process used in our exploit - including the alert story and details of the detected activity. \" class=\"wp-image-112722\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-7-Microsoft-Defender-for-Endpoint-detecting-a-suspicious-SUID-process-used-in-our-exploit.png 800w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-7-Microsoft-Defender-for-Endpoint-detecting-a-suspicious-SUID-process-used-in-our-exploit-300x160.png 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-7-Microsoft-Defender-for-Endpoint-detecting-a-suspicious-SUID-process-used-in-our-exploit-768x409.png 768w\" sizes=\"auto, (max-width: 800px) 100vw, 800px\" \/><figcaption class=\"wp-element-caption\">Figure 7: Microsoft Defender for Endpoint detecting a suspicious SUID process used in our exploit<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Defending against the evolving threat landscape requires the ability to protect and secure users\u2019 computing experiences, be it a Windows or non-Windows device. Microsoft continuously enriches our protection technologies through robust research that protects users and organizations across all the major platforms every single day. This case displayed how the ability to coordinate such research via expert, cross-industry collaboration is vital to effectively mitigate issues, regardless of the vulnerable device or platform in use. By sharing our research and other forms of threat intelligence, we can continue to collaborate with the larger security community and strive to build better protection for all.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Jonathan Bar Or<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft 365 Defender Research Team<\/p>\n","protected":false},"excerpt":{"rendered":"<p>Microsoft has discovered several vulnerabilities, collectively referred to as Nimbuspwn, that could be chained together, allowing an attacker to elevate privileges to root on many Linux desktop endpoints. Leveraging Nimbuspwn as a vector for root access could allow attackers to achieve greater impact on vulnerable devices by deploying payloads and performing other malicious actions via arbitrary root code execution.<\/p>\n","protected":false},"author":153,"featured_media":112725,"comment_status":"closed","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"ms_queue_id":[],"ep_exclude_from_search":false,"_classifai_error":"","_classifai_text_to_speech_error":"","_alt_title":"","ms-ems-related-posts":[],"footnotes":""},"post_tag":[3898,3782],"threat-intelligence":[3739],"content-type":[3663],"job-role":[],"product":[],"topic":[3687],"coauthors":[3380],"class_list":["post-112701","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","tag-elevation-of-privilege","tag-linux","threat-intelligence-vulnerabilities-and-exploits","content-type-research","topic-threat-intelligence","review-flag-1694638264-948","review-flag-1694638265-576","review-flag-1-1694638265-354","review-flag-2-1694638266-864","review-flag-3-1694638266-241","review-flag-4-1694638266-512","review-flag-5-1694638266-171","review-flag-6-1694638266-691","review-flag-7-1694638266-851","review-flag-lever-1694638263-909","review-flag-new-1694638263-340"],"yoast_head":"<!-- This site is optimized with the Yoast SEO plugin v27.2 - https:\/\/yoast.com\/product\/yoast-seo-wordpress\/ -->\n<title>Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog<\/title>\n<meta name=\"robots\" content=\"index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1\" \/>\n<link rel=\"canonical\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\" \/>\n<meta property=\"og:locale\" content=\"en_US\" \/>\n<meta property=\"og:type\" content=\"article\" \/>\n<meta property=\"og:title\" content=\"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog\" \/>\n<meta property=\"og:description\" content=\"Microsoft has discovered several vulnerabilities, collectively referred to as Nimbuspwn, that could be chained together, allowing an attacker to elevate privileges to root on many Linux desktop endpoints. Leveraging Nimbuspwn as a vector for root access could allow attackers to achieve greater impact on vulnerable devices by deploying payloads and performing other malicious actions via arbitrary root code execution.\" \/>\n<meta property=\"og:url\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\" \/>\n<meta property=\"og:site_name\" content=\"Microsoft Security Blog\" \/>\n<meta property=\"article:published_time\" content=\"2022-04-26T16:00:00+00:00\" \/>\n<meta property=\"article:modified_time\" content=\"2025-06-20T09:28:49+00:00\" \/>\n<meta property=\"og:image\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png\" \/>\n\t<meta property=\"og:image:width\" content=\"1200\" \/>\n\t<meta property=\"og:image:height\" content=\"800\" \/>\n\t<meta property=\"og:image:type\" content=\"image\/png\" \/>\n<meta name=\"author\" content=\"Microsoft Threat Intelligence\" \/>\n<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n<meta name=\"twitter:image\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race.png\" \/>\n<meta name=\"twitter:label1\" content=\"Written by\" \/>\n\t<meta name=\"twitter:data1\" content=\"Microsoft Threat Intelligence\" \/>\n\t<meta name=\"twitter:label2\" content=\"Est. reading time\" \/>\n\t<meta name=\"twitter:data2\" content=\"11 minutes\" \/>\n<script type=\"application\/ld+json\" class=\"yoast-schema-graph\">{\"@context\":\"https:\/\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#article\",\"isPartOf\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\"},\"author\":[{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/microsoft-security-threat-intelligence\/\",\"@type\":\"Person\",\"@name\":\"Microsoft Threat Intelligence\"}],\"headline\":\"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn\",\"datePublished\":\"2022-04-26T16:00:00+00:00\",\"dateModified\":\"2025-06-20T09:28:49+00:00\",\"mainEntityOfPage\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\"},\"wordCount\":2156,\"publisher\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage\"},\"thumbnailUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png\",\"keywords\":[\"Elevation of privilege\",\"Linux\"],\"articleSection\":[\"Cybersecurity\"],\"inLanguage\":\"en-US\"},{\"@type\":\"WebPage\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\",\"name\":\"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog\",\"isPartOf\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website\"},\"primaryImageOfPage\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage\"},\"thumbnailUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png\",\"datePublished\":\"2022-04-26T16:00:00+00:00\",\"dateModified\":\"2025-06-20T09:28:49+00:00\",\"breadcrumb\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#breadcrumb\"},\"inLanguage\":\"en-US\",\"potentialAction\":[{\"@type\":\"ReadAction\",\"target\":[\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/\"]}]},{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png\",\"contentUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png\",\"width\":1200,\"height\":800},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#breadcrumb\",\"itemListElement\":[{\"@type\":\"ListItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\"},{\"@type\":\"ListItem\",\"position\":2,\"name\":\"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn\"}]},{\"@type\":\"WebSite\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\",\"name\":\"Microsoft Security Blog\",\"description\":\"Expert coverage of cybersecurity topics\",\"publisher\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\"},\"potentialAction\":[{\"@type\":\"SearchAction\",\"target\":{\"@type\":\"EntryPoint\",\"urlTemplate\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?s={search_term_string}\"},\"query-input\":{\"@type\":\"PropertyValueSpecification\",\"valueRequired\":true,\"valueName\":\"search_term_string\"}}],\"inLanguage\":\"en-US\"},{\"@type\":\"Organization\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\",\"name\":\"Microsoft Security Blog\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\",\"logo\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png\",\"contentUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png\",\"width\":512,\"height\":512,\"caption\":\"Microsoft Security Blog\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/\"}},{\"@type\":\"Person\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/person\/fa785acae88a9b0cfe278a692ce196f5\",\"name\":\"Microsoft Security Threat Intelligence\",\"image\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g430eaf64ccad6ceda364c6ea504461c5\",\"url\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g\",\"contentUrl\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g\",\"caption\":\"Microsoft Security Threat Intelligence\"},\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/v-katiemc\/\"}]}<\/script>\n<!-- \/ Yoast SEO plugin. -->","yoast_head_json":{"title":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog","robots":{"index":"index","follow":"follow","max-snippet":"max-snippet:-1","max-image-preview":"max-image-preview:large","max-video-preview":"max-video-preview:-1"},"canonical":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/","og_locale":"en_US","og_type":"article","og_title":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog","og_description":"Microsoft has discovered several vulnerabilities, collectively referred to as Nimbuspwn, that could be chained together, allowing an attacker to elevate privileges to root on many Linux desktop endpoints. Leveraging Nimbuspwn as a vector for root access could allow attackers to achieve greater impact on vulnerable devices by deploying payloads and performing other malicious actions via arbitrary root code execution.","og_url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/","og_site_name":"Microsoft Security Blog","article_published_time":"2022-04-26T16:00:00+00:00","article_modified_time":"2025-06-20T09:28:49+00:00","og_image":[{"width":1200,"height":800,"url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png","type":"image\/png"}],"author":"Microsoft Threat Intelligence","twitter_card":"summary_large_image","twitter_image":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Figure-6-Our-exploit-implemented-and-winning-the-TOCTOU-race.png","twitter_misc":{"Written by":"Microsoft Threat Intelligence","Est. reading time":"11 minutes"},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#article","isPartOf":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/"},"author":[{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/microsoft-security-threat-intelligence\/","@type":"Person","@name":"Microsoft Threat Intelligence"}],"headline":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn","datePublished":"2022-04-26T16:00:00+00:00","dateModified":"2025-06-20T09:28:49+00:00","mainEntityOfPage":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/"},"wordCount":2156,"publisher":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png","keywords":["Elevation of privilege","Linux"],"articleSection":["Cybersecurity"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/","name":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn | Microsoft Security Blog","isPartOf":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website"},"primaryImageOfPage":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png","datePublished":"2022-04-26T16:00:00+00:00","dateModified":"2025-06-20T09:28:49+00:00","breadcrumb":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#primaryimage","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2022\/04\/Nimbuspwn-Featured-Image.png","width":1200,"height":800},{"@type":"BreadcrumbList","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2022\/04\/26\/microsoft-finds-new-elevation-of-privilege-linux-vulnerability-nimbuspwn\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/"},{"@type":"ListItem","position":2,"name":"Microsoft finds new elevation of privilege Linux vulnerability, Nimbuspwn"}]},{"@type":"WebSite","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/","name":"Microsoft Security Blog","description":"Expert coverage of cybersecurity topics","publisher":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?s={search_term_string}"},"query-input":{"@type":"PropertyValueSpecification","valueRequired":true,"valueName":"search_term_string"}}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization","name":"Microsoft Security Blog","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png","width":512,"height":512,"caption":"Microsoft Security Blog"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/"}},{"@type":"Person","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/person\/fa785acae88a9b0cfe278a692ce196f5","name":"Microsoft Security Threat Intelligence","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g430eaf64ccad6ceda364c6ea504461c5","url":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g","contentUrl":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g","caption":"Microsoft Security Threat Intelligence"},"url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/v-katiemc\/"}]}},"bloginabox_animated_featured_image":null,"bloginabox_display_generated_audio":false,"distributor_meta":false,"distributor_terms":false,"distributor_media":false,"distributor_original_site_name":"Microsoft Security Blog","distributor_original_site_url":"https:\/\/www.microsoft.com\/en-us\/security\/blog","push-errors":false,"_links":{"self":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/112701","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/users\/153"}],"replies":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/comments?post=112701"}],"version-history":[{"count":1,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/112701\/revisions"}],"predecessor-version":[{"id":139744,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/112701\/revisions\/139744"}],"wp:featuredmedia":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/media\/112725"}],"wp:attachment":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/media?parent=112701"}],"wp:term":[{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/post_tag?post=112701"},{"taxonomy":"threat-intelligence","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/threat-intelligence?post=112701"},{"taxonomy":"content-type","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/content-type?post=112701"},{"taxonomy":"job-role","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/job-role?post=112701"},{"taxonomy":"product","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/product?post=112701"},{"taxonomy":"topic","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/topic?post=112701"},{"taxonomy":"author","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/coauthors?post=112701"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}