{"id":131410,"date":"2023-08-24T09:30:00","date_gmt":"2023-08-24T16:30:00","guid":{"rendered":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?p=131410"},"modified":"2025-07-03T05:00:53","modified_gmt":"2025-07-03T12:00:53","slug":"flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations","status":"publish","type":"post","link":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/","title":{"rendered":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations"},"content":{"rendered":"\n<hr class=\"wp-block-separator has-alpha-channel-opacity\"\/>\n\n\n\n<p class=\"wp-block-paragraph\"><strong>Summary<\/strong><\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft has identified a nation-state activity group tracked as Flax Typhoon, based in China, that is targeting dozens of organizations in Taiwan with the likely intention of performing espionage. Flax Typhoon gains and maintains long-term access to Taiwanese organizations&#8217; networks with minimal use of malware, relying on tools built into the operating system, along with some normally benign software to quietly remain in these networks. Microsoft has not observed Flax Typhoon using this access to conduct additional actions. This blog aims to raise awareness of the techniques used by this threat actor and inform better defenses to protect against future attacks.<\/p>\n\n\n\n<hr class=\"wp-block-separator has-alpha-channel-opacity is-style-thin\"\/>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft has observed a distinctive pattern of malicious activity almost exclusively affecting organizations in Taiwan using techniques that could be easily reused in other operations outside the region and would benefit from broader industry visibility. Microsoft attributes this campaign to Flax Typhoon (overlaps with ETHEREAL PANDA), a nation-state actor based out of China. Flax Typhoon\u2019s observed behavior suggests that the threat actor intends to perform espionage and maintain access to organizations across a broad range of industries for as long as possible. However, Microsoft has not observed Flax Typhoon act on final objectives in this campaign. Microsoft is choosing to highlight this Flax Typhoon activity at this time because of our significant concern around the potential for further impact to our customers. Although our visibility into these threats has given us the ability to deploy detections to our customers, the lack of visibility into other parts of the actor\u2019s activity compelled us to drive broader community awareness to further investigations and protections across the security ecosystem.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">In this blog post, we share information on Flax Typhoon, the current campaign targeting Taiwan, and the actor\u2019s tactics for achieving and maintaining unauthorized access to target networks. Because this activity relies on valid accounts and living-off-the-land binaries (LOLBins), detecting and mitigating this attack could be challenging. Compromised accounts must be closed or changed. Compromised systems must be isolated and investigated. At the end of this blog post, we share more mitigation steps and best practices, as well as provide details on how Microsoft 365 Defender detects malicious and suspicious activity to protect organizations from such stealthy attacks.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"who-is-flax-typhoon\">Who is Flax Typhoon?<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon has been active since mid-2021 and has targeted government agencies and education, critical manufacturing, and information technology organizations in Taiwan. Some victims have also been observed elsewhere in Southeast Asia, as well as in North America and Africa. Flax Typhoon focuses on persistence, lateral movement, and credential access. As with any observed nation-state actor activity, Microsoft has directly notified targeted or compromised customers, providing them with important information needed to secure their environments.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon is known to use the <em>China Chopper<\/em> web shell, Metasploit, Juicy Potato privilege escalation tool, Mimikatz, and SoftEther virtual private network (VPN) client. However, Flax Typhoon primarily relies on <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2018\/09\/27\/out-of-sight-but-not-invisible-defeating-fileless-malware-with-behavior-monitoring-amsi-and-next-gen-av\/\">living-off-the-land techniques<\/a> and hands-on-keyboard activity. Flax Typhoon achieves initial access by exploiting known vulnerabilities in public-facing servers and deploying web shells like <em>China Chopper<\/em>. Following initial access, Flax Typhoon uses command-line tools to first establish persistent access over the remote desktop protocol, then deploy a VPN connection to actor-controlled network infrastructure, and finally collect credentials from compromised systems. Flax Typhoon further uses this VPN access to scan for vulnerabilities on targeted systems and organizations from the compromised systems.<\/p>\n\n\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-1024x336.webp\" alt=\"Flax Typhoon attack chain through the initial access, execution, persistence, privilege escalation, defense evasion, credential access, discovery, lateral movement, and command and control stages.\" class=\"wp-image-131413 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-1024x336.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-300x98.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-768x252.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-1536x504.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-2048x672.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-1.-Flax-Typhoon-attack-chain-diagram-1024x336.webp\"><figcaption class=\"wp-element-caption\">Figure 1. Flax Typhoon attack chain<\/figcaption><\/figure>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"analysis-of-current-campaign\">Analysis of current campaign<\/h2>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"initial-access\">Initial access<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon achieves initial access by <a href=\"https:\/\/attack.mitre.org\/techniques\/T1190\" target=\"_blank\" rel=\"noreferrer noopener\">exploiting<\/a> known vulnerabilities in public-facing servers. The services targeted vary, but include VPN, web, Java, and SQL applications. The payload in these exploits is a <a href=\"https:\/\/attack.mitre.org\/techniques\/T1505\/003\/\" target=\"_blank\" rel=\"noreferrer noopener\">web shell<\/a>, such as <a href=\"https:\/\/attack.mitre.org\/software\/S0020\/\" target=\"_blank\" rel=\"noreferrer noopener\"><em>China Chopper<\/em><\/a>, which allows for remote code execution on the compromised server.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"privilege-escalation\">Privilege escalation<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">In cases where the process compromised via web shell does not have local administrator privileges, Flax Typhoon downloads and runs a piece of malware that exploits one or more known vulnerabilities to obtain local system privileges. Microsoft has observed the actor use <a href=\"https:\/\/github.com\/ohpe\/juicy-potato\" target=\"_blank\" rel=\"noreferrer noopener\">Juicy Potato<\/a>, <a href=\"https:\/\/github.com\/BeichenDream\/BadPotato\" target=\"_blank\" rel=\"noreferrer noopener\">BadPotato<\/a>, and other open-source tools to exploit these vulnerabilities.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"persistence\">Persistence<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">Once Flax Typhoon can access Windows Management Instrumentation command-line (WMIC), PowerShell, or the Windows Terminal with local administrator privileges, the actor establishes a long-term method of <a href=\"https:\/\/attack.mitre.org\/techniques\/T1059\" target=\"_blank\" rel=\"noreferrer noopener\">accessing<\/a> the compromised system using the remote desktop protocol (RDP). To accomplish this, the actor <a href=\"https:\/\/learn.microsoft.com\/previous-versions\/windows\/it-pro\/windows-server-2008-R2-and-2008\/cc732713(v=ws.11)\">disables network-level authentication (NLA)<\/a> for RDP, replaces the Sticky Keys binary, and establishes a VPN connection.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">When using RDP, NLA requires the connecting user to authenticate to the remote system before a full remote session is established and the Windows sign-in screen is displayed. When NLA is disabled, any user attempting to access the remote system can interact with the Windows sign-in screen before authenticating, which can expose the remote system to malicious actions by the connecting user. Flax Typhoon changes a registry key to disable NLA, allowing them to access the Windows sign-in screen without authenticating, whereupon the actor will use the Sticky Keys shortcut.<\/p>\n\n\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-1024x79.webp\" alt=\"Screenshot of code depicting Flax Typhoon's NLA disabling command\" class=\"wp-image-131414 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-1024x79.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-300x23.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-768x59.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-1536x118.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-2048x157.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-2.-Flax-Typhoon-command-disabling-NLA-1024x79.webp\"><figcaption class=\"wp-element-caption\">Figure 2. Flax Typhoon command disabling NLA<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Sticky Keys is an <a href=\"https:\/\/support.microsoft.com\/windows\/windows-keyboard-shortcuts-for-accessibility-021bcb62-45c8-e4ef-1e4f-41b8c1fc87fd\">accessibility feature<\/a> in Windows that allows users to press modifier keys (such as <em>Shift<\/em>, <em>Ctrl<\/em>, <em>Alt<\/em>) one at a time instead of simultaneously. It includes a shortcut where the user can press the <em>Shift<\/em> key five times in succession to launch <em>sethc.exe<\/em>, the program that manages Sticky Keys. The user can invoke this shortcut at any time, including at the sign-in screen. To <a href=\"https:\/\/attack.mitre.org\/techniques\/T1546\/008\/\" target=\"_blank\" rel=\"noreferrer noopener\">take advantage of this feature<\/a>, Flax Typhoon changes a registry key that specifies the location of <em>sethc.exe<\/em>. The actor adds arguments that cause the Windows Task Manager to be launched as a debugger for <em>sethc.exe<\/em>. As a result, when the actor uses the Sticky Keys shortcut on the Windows sign-in screen, Task Manager launches with local system privileges.<\/p>\n\n\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-1024x95.webp\" alt=\"Screenshot of code depicting Flax Typhoon's Sticky Keys behavior altering command\" class=\"wp-image-131415 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-1024x95.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-300x28.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-768x71.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-1536x143.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-2048x191.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-3.-Flax-Typhoon-command-altering-Sticky-Keys-behavior-1024x95.webp\"><figcaption class=\"wp-element-caption\">Figure 3. Flax Typhoon command altering Sticky Keys behavior<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">At this stage, Flax Typhoon can access the compromised system via RDP, use the Sticky Keys shortcut at the sign-in screen, and access Task Manager with local system privileges. From there, the actor can launch the Terminal, create memory dumps, and take nearly any other action on the compromised system. The only issue the actor faces with this persistence method is that RDP is most likely running on an internal-facing network interface. Flax Typhoon\u2019s solution is to install a legitimate VPN bridge to automatically connect to actor-controlled network infrastructure.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"command-and-control\">Command and control<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">To deploy the VPN connection, Flax Typhoon <a href=\"https:\/\/attack.mitre.org\/techniques\/T1105\/\" target=\"_blank\" rel=\"noreferrer noopener\">downloads<\/a> an executable file for <a href=\"https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable\" target=\"_blank\" rel=\"noreferrer noopener\">SoftEther VPN<\/a> from their network infrastructure. The actor downloads the tool using one of several LOLBins, such as the PowerShell <a href=\"https:\/\/learn.microsoft.com\/powershell\/module\/microsoft.powershell.utility\/invoke-webrequest?view=powershell-7.3\">Invoke-WebRequest<\/a> utility, <a href=\"https:\/\/learn.microsoft.com\/windows-server\/administration\/windows-commands\/certutil\">certutil<\/a>, or <a href=\"https:\/\/learn.microsoft.com\/windows-server\/administration\/windows-commands\/bitsadmin\">bitsadmin<\/a>. Flax Typhoon then uses the <a href=\"https:\/\/learn.microsoft.com\/previous-versions\/windows\/it-pro\/windows-server-2012-R2-and-2012\/cc990289(v=ws.11)\">Service Control Manager (SCM)<\/a> to <a href=\"https:\/\/attack.mitre.org\/techniques\/T1543\/003\" target=\"_blank\" rel=\"noreferrer noopener\">create a Windows service<\/a> that launches the VPN connection automatically when the system starts. This could allow the actor to monitor the availability of the compromised system and establish an RDP connection.<\/p>\n\n\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-1024x94.webp\" alt=\"Screenshot of code depicting Flax Typhoon's SoftEther VPN download command\" class=\"wp-image-131416 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-1024x94.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-300x27.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-768x70.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-1536x140.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-2048x187.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-4.-Flax-Typhoon-command-downloading-a-SoftEther-VPN-executable-1024x94.webp\"><figcaption class=\"wp-element-caption\">Figure 4. Flax Typhoon command downloading a SoftEther VPN executable<\/figcaption><\/figure>\n\n\n<figure class=\"wp-block-image size-large\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-1024x121.webp\" alt=\"Screenshot of code depicting Flax Typhoon's service command to launch the VPN connection\" class=\"wp-image-131417 webp-format\" srcset=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-1024x121.webp 1024w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-300x35.webp 300w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-768x90.webp 768w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-1536x181.webp 1536w, https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-2048x241.webp 2048w\" data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Figure-5.-Flax-Typhoon-command-creating-a-service-to-launch-the-VPN-connection-1024x121.webp\"><figcaption class=\"wp-element-caption\">Figure 5. Flax Typhoon command creating a service to launch the VPN connection<\/figcaption><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon takes several precautions with their VPN connection to make it harder to identify. First, the actor uses a legitimate VPN application that could be found in enterprise environments. As a result, the file itself is almost certain to go undetected by antivirus products. Second, the actor almost always <a href=\"https:\/\/attack.mitre.org\/techniques\/T1036\/005\/\" target=\"_blank\" rel=\"noreferrer noopener\">renames the executable file<\/a> from <em>vpnbridge.exe<\/em> to <em>conhost.exe<\/em> or <em>dllhost.exe<\/em>. These names imitate the legitimate Windows components Console Window Host Process and Component Object Model Surrogate respectively. Third, the actor uses SoftEther\u2019s <a href=\"https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable\/blob\/master\/WARNING.TXT\" target=\"_blank\" rel=\"noreferrer noopener\">VPN-over-HTTPS<\/a> operation mode, which uses <a href=\"https:\/\/attack.mitre.org\/techniques\/T1572\/\" target=\"_blank\" rel=\"noreferrer noopener\">protocol tunneling<\/a> to encapsulate Ethernet packets into compliant HTTPS packets and transmit them to TCP port 443. This makes the VPN connection very difficult to differentiate from legitimate HTTPS traffic, which most network security appliances would not block.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">In cases where Flax Typhoon needs to move laterally to access other systems on the compromised network, the actor uses LOLBins, including Windows Remote Management (WinRM) and WMIC.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft has observed Flax Typhoon routing network traffic to other targeted systems through the SoftEther VPN bridge installed on compromised systems. This network traffic includes network scanning, vulnerability scanning, and exploitation attempts.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"credential-access\">Credential access<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">Once Flax Typhoon becomes established on the target system, Microsoft observes the actor conducting credential access activities using common tools and techniques. Most commonly, Flax Typhoon targets the Local Security Authority Subsystem Service <a href=\"https:\/\/attack.mitre.org\/techniques\/T1003\/001\/\" target=\"_blank\" rel=\"noreferrer noopener\">(LSASS) process memory<\/a> and Security Account Manager <a href=\"https:\/\/attack.mitre.org\/techniques\/T1003\/002\/\" target=\"_blank\" rel=\"noreferrer noopener\">(SAM) registry hive<\/a>. Both stores contain hashed passwords for users signed into the local system. Flax Typhoon frequently deploys Mimikatz, a publicly available malware that can automatically dump these stores when <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/10\/05\/detecting-and-preventing-lsass-credential-dumping-attacks\/\">improperly secured<\/a>. The resulting password hashes can be cracked offline or used in <a href=\"https:\/\/attack.mitre.org\/techniques\/T1550\/002\/\" target=\"_blank\" rel=\"noreferrer noopener\">pass-the-hash (PtH) attacks<\/a> to access other resources on the compromised network.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon also enumerates restore points used by <a href=\"https:\/\/support.microsoft.com\/windows\/use-system-restore-a5ae3ed9-07c4-fd56-45ee-096777ecd14e\">System Restore<\/a>. Restore points contain data about the Windows operating system that the system owner can use to revert changes to the system if it becomes inoperable, rather than a backup of user data. Flax Typhoon could use this information to better understand the compromised system or as a template for removing indicators of malicious activity.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">This pattern of activity is unusual in that minimal activity occurs after the actor establishes persistence. Flax Typhoon\u2019s discovery and credential access activities do not appear to enable further data-collection and exfiltration objectives. While the actor\u2019s observed behavior suggests Flax Typhoon intents to perform espionage and maintain their network footholds, Microsoft has not observed Flax Typhoon act on final objectives in this campaign.<\/p>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"mitigation-and-protection-guidance\">Mitigation and protection guidance<\/h2>\n\n\n\n<p class=\"wp-block-paragraph\">Defending against techniques used by Flax Typhoon begins with vulnerability and patch management, particularly on systems and services exposed to the public internet. The credential access techniques used can also be mitigated with proper system hardening.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"what-to-do-now-if-you-re-affected\">What to do now if you\u2019re affected<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">Affected organizations need to assess the scale of Flax Typhoon activity in their network, remove malicious tools and C2 infrastructure, and check logs for signs of compromised accounts that may have been used for malicious purposes.<\/p>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"investigating-suspected-compromised-accounts-or-affected-systems\">Investigating Suspected compromised accounts or affected systems<\/h3>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Find <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/10\/05\/detecting-and-preventing-lsass-credential-dumping-attacks\/\">LSASS<\/a> and SAM dumping to identify affected accounts.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Examine the activity of compromised accounts for any malicious actions or exposed data.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Close or change credentials for all compromised accounts. Depending on the level of activity, many accounts may be affected.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Affected systems should be isolated and forensically examined for artifacts of malicious activity.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Because Flax Typhoon alters the configuration of the operating system to produce malicious behavior, affected systems may need to be decommissioned or restored to a known-good configuration.<\/li>\n<\/ul>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"defending-against-flax-typhoon-attacks\">Defending against Flax Typhoon attacks<\/h3>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Keep public-facing servers up to date to defend against malicious activity. As prime targets for threat actors, public-facing servers need additional monitoring and security. User input validation, file integrity monitoring, behavioral monitoring, and web application firewalls can all help to better secure these servers.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Monitor the Windows registry for unauthorized changes. The <a href=\"https:\/\/learn.microsoft.com\/windows\/security\/threat-protection\/auditing\/audit-registry\">Audit Registry<\/a> feature allows administrators to generate events when specific registry keys are modified. Such policies can detect registry changes that undermine the security of a system, like those made by Flax Typhoon.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Use network monitoring and intrusion detection systems to identify unusual or unauthorized network traffic. If an organization does not use RDP for a specific business purpose, any RDP traffic should be considered unauthorized and generate alerts.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Ensure that Windows systems are kept updated with the latest security patches, including <a href=\"https:\/\/learn.microsoft.com\/security-updates\/securitybulletins\/2016\/ms16-075\">MS16-075<\/a>.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Mitigate the risk of compromised valid accounts by enforcing strong multifactor authentication (MFA) policies using hardware security keys or Microsoft Authenticator. <a href=\"https:\/\/learn.microsoft.com\/azure\/active-directory\/authentication\/concept-authentication-passwordless\">Passwordless sign-in<\/a> methods (for example, Windows Hello, FIDO2 security keys, or Microsoft Authenticator), password expiration rules, and deactivating unused accounts can also help mitigate risk from this access method.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Randomize Local Administrator passwords with a tool like <a href=\"https:\/\/learn.microsoft.com\/windows-server\/identity\/laps\/laps-overview\">Local Administrator Password Solution (LAPS)<\/a> to prevent lateral movement using local accounts with shared passwords.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Reduce the attack surface. Microsoft customers can turn on the following&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/overview-attack-surface-reduction\">attack surface reduction<\/a>&nbsp;rules to block or audit some observed activity associated with this threat:\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction-rules-reference?#block-credential-stealing-from-the-windows-local-security-authority-subsystem\">Block credential stealing<\/a>&nbsp;from the Windows local security authority subsystem (<em>lsass.exe<\/em>).<\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction-rules-reference?#block-process-creations-originating-from-psexec-and-wmi-commands\">Block process creations<\/a>&nbsp;originating from PSExec and WMI commands. Some organizations may experience compatibility issues with this rule on certain server systems but should deploy it to other systems to prevent lateral movement originating from PsExec and WMI.<\/li>\n<\/ul>\n<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Harden the LSASS process by enabling&nbsp;<a href=\"https:\/\/learn.microsoft.com\/windows-server\/security\/credentials-protection-and-management\/configuring-additional-lsa-protection#BKMK_HowToConfigure\">Protective Process Light (PPL) for LSASS<\/a>&nbsp;on Windows 11 devices. New, enterprise-joined Windows 11 (22H2 update) installs have this feature enabled by default. In addition, enable&nbsp;<a href=\"https:\/\/learn.microsoft.com\/windows\/security\/identity-protection\/credential-guard\/credential-guard-manage#enable-windows-defender-credential-guard\">Windows Defender Credential Guard<\/a>, which is also turned on by default for organizations using the Enterprise edition of Windows 11, as well as <a href=\"https:\/\/learn.microsoft.com\/windows\/security\/hardware-security\/enable-virtualization-based-protection-of-code-integrity\">Memory integrity<\/a> (also referred to as hypervisor-protected code integrity or HVCI) for stronger protections on Windows.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Set the <a href=\"https:\/\/support.microsoft.com\/topic\/microsoft-security-advisory-update-to-improve-credentials-protection-and-management-may-13-2014-93434251-04ac-b7f3-52aa-9f951c14b649\">WDigest UseLogonCredential<\/a> registry value via Group Policy Object to reduce the risk of successful LSASS process memory dumping.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Turn on&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/configure-block-at-first-sight-microsoft-defender-antivirus?ocid=magicti_ta_learndoc\">cloud-delivered protection<\/a>&nbsp;in Microsoft Defender Antivirus to cover rapidly evolving attacker tools, techniques, and behaviors such as those exhibited by Flax Typhoon.<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Run&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/edr-in-block-mode?ocid=magicti_ta_learndoc\">endpoint detection and response (EDR) in block mode<\/a>&nbsp;so that Microsoft Defender for Endpoint can block malicious artifacts, even when your non-Microsoft antivirus does not detect the threat, or when Microsoft Defender Antivirus is running in passive mode. EDR in block mode works behind the scenes to remediate malicious artifacts that are detected post-compromise.<\/li>\n<\/ul>\n\n\n\n<h2 class=\"wp-block-heading\" id=\"detection-details-and-hunting-queries\">Detection details and hunting queries<\/h2>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"microsoft-365-defender-detections\">Microsoft 365 Defender detections<\/h3>\n\n\n\n<blockquote class=\"wp-block-quote blockquote is-layout-flow wp-block-quote-is-layout-flow has-quote-default-font-size\">\n<p class=\"wp-block-paragraph\">Microsoft 365 Defender is becoming Microsoft Defender XDR. <a href=\"https:\/\/aka.ms\/xdrignite2023\">Learn more<\/a>.<\/p>\n<\/blockquote>\n\n\n\n<p class=\"wp-block-paragraph\"><strong>Microsoft Defender Antivirus<\/strong><\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft Defender Antivirus detects threat components as the following malware:<\/p>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/www.microsoft.com\/en-us\/wdsi\/threats\/malware-encyclopedia-description?Name=HackTool:Win32\/Mimikatz\">HackTool:Win32\/Mimikatz<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/www.microsoft.com\/en-us\/wdsi\/threats\/malware-encyclopedia-description?Name=Trojan:Win32\/Swrort.A&amp;threatId=-2147336533\">Trojan:Win32\/Swrort<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/www.microsoft.com\/en-us\/wdsi\/threats\/malware-encyclopedia-description?Name=HackTool:Win32\/Badcastle.A!dha&amp;threatId=-2147191632\">HackTool:Win32\/Badcastle<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/www.microsoft.com\/en-us\/wdsi\/threats\/malware-encyclopedia-description?Name=Behavior:Win32\/CobaltStrike.I!nri&amp;threatId=-2147181941\">Behavior:Win32\/CobaltStrike<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/www.microsoft.com\/en-us\/wdsi\/threats\/malware-encyclopedia-description?Name=Backdoor:ASP\/Chopper.ZC!dha&amp;threatId=-2147152222\">Backdoor:ASP\/Chopper<\/a><\/li>\n<\/ul>\n\n\n\n<p class=\"wp-block-paragraph\"><strong>Microsoft Defender for Endpoint<\/strong><\/p>\n\n\n\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity related to this threat. Note, however, that these alerts can also be triggered by unrelated threat activity.<\/p>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Malicious credential theft tool execution detected<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Suspicious access to LSASS service<\/li>\n\n\n\n<li class=\"wp-block-list-item\">Use of LOLBin to run malicious code<\/li>\n\n\n\n<li class=\"wp-block-list-item\">System file masquerade<\/li>\n<\/ul>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"hunting-queries\">Hunting queries<\/h3>\n\n\n\n<h4 class=\"wp-block-heading\" id=\"microsoft-365-defender\">Microsoft 365 Defender<\/h4>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft 365 Defender customers can run the following queries to find related activity in their networks:<\/p>\n\n\n\n<p class=\"wp-block-paragraph\"><strong>Network activity with Flax Typhoon network infrastructure<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nlet ipAddressTimes = datatable(ip: string, startDate: datetime, endDate: datetime)\n[\n    \"101.33.205.106\", datetime(\"2022-11-07\"), datetime(\"2022-11-08\"),\n    \"39.98.208.61\", datetime(\"2023-07-28\"), datetime(\"2023-08-12\"),\n    \"45.195.149.224\", datetime(\"2023-01-04\"), datetime(\"2023-03-29\"),\n    \"122.10.89.230\", datetime(\"2023-01-12\"), datetime(\"2023-01-13\"),\n    \"45.204.1.248\", datetime(\"2023-02-23\"), datetime(\"2023-05-09\"),\n    \"45.204.1.247\", datetime(\"2023-07-24\"), datetime(\"2023-08-10\"),\n    \"45.88.192.118\", datetime(\"2022-11-07\"), datetime(\"2022-11-08\"),\n    \"154.19.187.92\", datetime(\"2022-12-01\"), datetime(\"2022-12-02\"),\n    \"134.122.188.20\", datetime(\"2023-06-13\"), datetime(\"2023-06-20\"),\n    \"104.238.149.146\", datetime(\"2023-07-13\"), datetime(\"2023-07-14\"),\n    \"139.180.158.51\", datetime(\"2022-08-30\"), datetime(\"2023-07-27\"),\n    \"137.220.36.87\", datetime(\"2023-02-23\"), datetime(\"2023-08-04\"),\n    \"192.253.235.107\", datetime(\"2023-06-06\"), datetime(\"2023-06-07\")\n];\nlet RemoteIPFiltered = DeviceNetworkEvents\n    | join kind=inner (ipAddressTimes) on $left.RemoteIP == $right.ip\n    | where Timestamp between (startDate .. endDate);\nlet LocalIPFiltered = DeviceNetworkEvents\n    | join kind=inner (ipAddressTimes) on $left.LocalIP == $right.ip\n    | where Timestamp between (startDate .. endDate);\nunion RemoteIPFiltered, LocalIPFiltered\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>SoftEther VPN bridge launched by SQL Server process<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceProcessEvents \n| where ProcessVersionInfoOriginalFileName == \"vpnbridge.exe\" or ProcessVersionInfoFileDescription == \"SoftEther VPN\"  \n| where InitiatingProcessParentFileName == \"sqlservr.exe\"\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>SoftEther VPN bridge renamed to \u201cconhost.exe\u201d or \u201cdllhost.exe\u201d<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceProcessEvents \n| where ProcessVersionInfoOriginalFileName == \"vpnbridge.exe\" or ProcessVersionInfoFileDescription == \"SoftEther VPN\"  \n| where ProcessCommandLine has_any (\"conhost.exe\", \"dllhost.exe\") or FolderPath has_any (\"mssql\", \"conhost.exe\", \"dllhost.exe\")\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>Certutil launched by SQL Server process<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceProcessEvents \n| where ProcessCommandLine has_all (\"certutil\", \"-urlcache\") \n| where InitiatingProcessFileName has_any (\"sqlservr.exe\", \"sqlagent.exe\", \"sqlps.exe\", \"launchpad.exe\", \"sqldumper.exe\")\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>File downloaded by MSSQLSERVER account using certutil<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceFileEvents \n| where InitiatingProcessAccountName == \"MSSQLSERVER\"  \n| where InitiatingProcessFileName == \"certutil.exe\"\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>File renamed to \u201cconhost.exe\u201d or \u201cdllhost.exe\u201d, downloaded using certutil<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceFileEvents \n| where InitiatingProcessFileName == \"certutil.exe\" \n| where FileName in (\"conhost.exe\", \"dllhost.exe\") \n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>Network connection made by SoftEther VPN bridge renamed to \u201cconhost.exe\u201d or \u201cdllhost.exe\u201d<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceNetworkEvents \n| where InitiatingProcessVersionInfoOriginalFileName == \"vpnbridge.exe\" or InitiatingProcessVersionInfoProductName == \"SoftEther VPN\" \n| where InitiatingProcessFileName == \"conhost.exe\"\n<\/pre><\/div>\n\n\n<p class=\"wp-block-paragraph\"><strong>Network connection made by MSSQLSERVER account, using SoftEther VPN bridge<\/strong><\/p>\n\n\n<div class=\"wp-block-syntaxhighlighter-code \"><pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title=\"\">\nDeviceNetworkEvents \n| where InitiatingProcessVersionInfoOriginalFileName == \"vpnbridge.exe\" or InitiatingProcessVersionInfoProductName == \"SoftEther VPN\" \n| where InitiatingProcessAccountName == \"MSSQLSERVER\"\n<\/pre><\/div>\n\n\n<h4 class=\"wp-block-heading\" id=\"microsoft-sentinel\">Microsoft Sentinel<\/h4>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with \u2018TI map\u2019) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from the Microsoft Sentinel Content Hub to have the analytics rule deployed in their Sentinel workspace. More details on the Content Hub can be found here:&nbsp; <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy\">https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy<\/a>.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">Microsoft Sentinel also has a range of detection and threat hunting content that customers can use to detect the post exploitation activity detailed in this blog in addition to Microsoft 365 Defender detections list above.<\/p>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Web%20Shells%20Threat%20Protection\/Hunting%20Queries\/Possible%20webshell%20drop.yaml\">Possible web shell drop<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/271cef1a17bc0f15e0df09a192b70075693eeba4\/Solutions\/Web%20Shells%20Threat%20Protection\/Hunting%20Queries\/WebShellActivity.yaml#L35\">Web shell activity<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/271cef1a17bc0f15e0df09a192b70075693eeba4\/Hunting%20Queries\/SecurityEvent\/PotentialLocalExploitationForPrivilegeEscalation.yaml#L2\">Potential local privilege escalation<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/UEBA%20Essentials\/Hunting%20Queries\/Anomalous%20RDP%20Activity.yaml\">Anomalous RDP activity<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/271cef1a17bc0f15e0df09a192b70075693eeba4\/Detections\/SecurityEvent\/AccessibilityFeaturesModification.yaml#L5\">Accessibility features modification<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Endpoint%20Threat%20Protection%20Essentials\/Hunting%20Queries\/Certutil-LOLBins.yaml\">Certutil-LOLBins<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/bdf92680be3c5c9aa28a6272807921555ac0971e\/Hunting%20Queries\/Microsoft%20365%20Defender\/Execution\/Bitsadmin%20Activity.yaml#L2\">Bitsadmin activity<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/master\/Solutions\/Windows%20Security%20Events\/Hunting%20Queries\/SuspectedLSASSDump.yaml\">Suspected LSASS dump<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/Azure\/Azure-Sentinel\/blob\/bdf92680be3c5c9aa28a6272807921555ac0971e\/Solutions\/Attacker%20Tools%20Threat%20Protection%20Essentials\/Analytic%20Rules\/CredentialDumpingServiceInstallation.yaml#L4\">Credential dumping service installation<\/a><\/li>\n<\/ul>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"indicators-of-compromise\">Indicators of compromise<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">In addition to compromised SOHO devices and compromised devices used for traffic proxying, Flax Typhoon maintains actor-controlled network infrastructure, including virtual private servers (VPS). Over the course of the campaign, the IP addresses listed in the table below were used during the corresponding timeframes.<\/p>\n\n\n\n<figure class=\"wp-block-table table\"><table><tbody><tr><td><strong>IP address<\/strong><\/td><td><strong>First seen<\/strong><\/td><td><strong>Last seen<\/strong><\/td><td><strong>Description<\/strong><\/td><\/tr><tr><td>101.33.205[.]106<\/td><td>2022-11-07<\/td><td>2022-11-07<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>39.98.208[.]61<\/td><td>2023-07-28<\/td><td>2023-08-11<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>45.195.149[.]224<\/td><td>2023-01-04<\/td><td>2023-03-28<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>122.10.89[.]230<\/td><td>2023-01-12<\/td><td>2023-01-12<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>45.204.1[.]248<\/td><td>2023-02-23<\/td><td>2023-05-09<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>45.204.1[.]247<\/td><td>2023-07-24<\/td><td>2023-08-09<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>45.88.192[.]118<\/td><td>2022-11-07<\/td><td>2022-11-07<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>154.19.187[.]92<\/td><td>2022-12-01<\/td><td>2022-12-01<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>134.122.188[.]20<\/td><td>2023-06-13<\/td><td>2023-06-19<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>104.238.149[.]146<\/td><td>2023-07-13<\/td><td>2023-07-13<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>139.180.158[.]51<\/td><td>2022-08-30<\/td><td>2023-07-26<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><tr><td>192.253.235[.]107<\/td><td>2023-06-06<\/td><td>2023-06-06<\/td><td>Flax Typhoon network infrastructure<\/td><\/tr><\/tbody><\/table><\/figure>\n\n\n\n<p class=\"wp-block-paragraph\">Flax Typhoon hosts its SofEther VPN servers on its own network infrastructure. Because the servers use the HTTPS protocol to disguise network traffic, they must present TLS certificates. Flax Typhoon used the certificates listed in the table below on these VPN servers.<\/p>\n\n\n\n<figure class=\"wp-block-table table\"><table><tbody><tr><td><strong>SHA-1 TLS fingerprint<\/strong><\/td><td><strong>Common name (CN)<\/strong><\/td><\/tr><tr><td>7992c0a816246b287d991c4ecf68f2d32e4bca18<\/td><td>vpn437972693.sednc[.]cn<\/td><\/tr><tr><td>5437d0195c31bf7cedc9d90b8cb0074272bc55df<\/td><td>asljkdqhkhasdq.softether[.]net<\/td><\/tr><tr><td>cc1f0cdc131dfafd43f60ff0e6a6089cd03e92f1<\/td><td>vpn472462384.softether[.]net<\/td><\/tr><tr><td>2c95b971aa47dc4d94a3c52db74a3de11d9ba658<\/td><td>softether<\/td><\/tr><\/tbody><\/table><\/figure>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"references\">References<\/h3>\n\n\n\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1190\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1190<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1505\/003\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1505\/003\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/software\/S0020\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/software\/S0020\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/ohpe\/juicy-potato\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/github.com\/ohpe\/juicy-potato<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/BeichenDream\/BadPotato\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/github.com\/BeichenDream\/BadPotato<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1059\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1059<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1546\/008\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1546\/008\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1105\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1105\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1543\/003\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1543\/003<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1036\/005\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1036\/005\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable\/blob\/master\/WARNING.TXT\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/github.com\/SoftEtherVPN\/SoftEtherVPN_Stable\/blob\/master\/WARNING.TXT<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1572\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1572\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1003\/001\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1003\/001\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1003\/002\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1003\/002\/<\/a><\/li>\n\n\n\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/attack.mitre.org\/techniques\/T1550\/002\/\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/attack.mitre.org\/techniques\/T1550\/002\/<\/a><\/li>\n<\/ul>\n\n\n\n<h3 class=\"wp-block-heading\" id=\"further-reading\">Further reading<\/h3>\n\n\n\n<p class=\"wp-block-paragraph\">For the latest security research from the Microsoft Threat Intelligence community, check out the Microsoft Threat Intelligence Blog:&nbsp;<a href=\"https:\/\/aka.ms\/threatintelblog\">https:\/\/aka.ms\/threatintelblog<\/a>.<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">To get notified about new publications and to join discussions on social media, follow us at&nbsp;<a href=\"https:\/\/twitter.com\/MsftSecIntel\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/twitter.com\/MsftSecIntel<\/a>.<\/p>\n","protected":false},"excerpt":{"rendered":"<p>China-based actor Flax Typhoon is exploiting known vulnerabilities for public-facing servers, legitimate VPN software, and open-source malware to gain access to Taiwanese organizations, but not taking further action.<\/p>\n","protected":false},"author":153,"featured_media":131423,"comment_status":"closed","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"ms_queue_id":[],"ep_exclude_from_search":false,"_classifai_error":"","_classifai_text_to_speech_error":"","_alt_title":"","ms-ems-related-posts":[130969,130214,130883,118778],"footnotes":""},"post_tag":[3921,3928],"threat-intelligence":[3727,3738,3739],"content-type":[3663],"job-role":[],"product":[3690,3694,3693,3726],"topic":[3687],"coauthors":[3380],"class_list":["post-131410","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","tag-living-off-the-land","tag-typhoon","threat-intelligence-attacker-techniques-tools-and-infrastructure","threat-intelligence-threat-actors","threat-intelligence-vulnerabilities-and-exploits","content-type-research","product-microsoft-defender","product-microsoft-defender-for-endpoint","product-microsoft-defender-xdr","product-microsoft-sentinel","topic-threat-intelligence","review-flag-1694638265-576","review-flag-1694638271-781","review-flag-1-1694638265-354","review-flag-2-1694638266-864","review-flag-3-1694638266-241","review-flag-4-1694638266-512","review-flag-5-1694638266-171","review-flag-alway-1694638263-571","review-flag-disable","review-flag-disabled","review-flag-infor-1694638272-144","review-flag-new-1694638263-340"],"yoast_head":"<!-- This site is optimized with the Yoast SEO plugin v27.2 - https:\/\/yoast.com\/product\/yoast-seo-wordpress\/ -->\n<title>Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog<\/title>\n<meta name=\"description\" content=\"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.\" \/>\n<meta name=\"robots\" content=\"index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1\" \/>\n<link rel=\"canonical\" href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\" \/>\n<meta property=\"og:locale\" content=\"en_US\" \/>\n<meta property=\"og:type\" content=\"article\" \/>\n<meta property=\"og:title\" content=\"Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog\" \/>\n<meta property=\"og:description\" content=\"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.\" \/>\n<meta property=\"og:url\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\" \/>\n<meta property=\"og:site_name\" content=\"Microsoft Security Blog\" \/>\n<meta property=\"article:published_time\" content=\"2023-08-24T16:30:00+00:00\" \/>\n<meta property=\"article:modified_time\" content=\"2025-07-03T12:00:53+00:00\" \/>\n<meta property=\"og:image\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Twitter-card-Flax-Typhoon-1.png\" \/>\n\t<meta property=\"og:image:width\" content=\"4096\" \/>\n\t<meta property=\"og:image:height\" content=\"2304\" \/>\n\t<meta property=\"og:image:type\" content=\"image\/png\" \/>\n<meta name=\"author\" content=\"Microsoft Threat Intelligence\" \/>\n<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n<meta name=\"twitter:image\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Twitter-card-Flax-Typhoon-1.png\" \/>\n<meta name=\"twitter:label1\" content=\"Written by\" \/>\n\t<meta name=\"twitter:data1\" content=\"Microsoft Threat Intelligence\" \/>\n\t<meta name=\"twitter:label2\" content=\"Est. reading time\" \/>\n\t<meta name=\"twitter:data2\" content=\"14 minutes\" \/>\n<script type=\"application\/ld+json\" class=\"yoast-schema-graph\">{\"@context\":\"https:\/\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#article\",\"isPartOf\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\"},\"author\":[{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/microsoft-security-threat-intelligence\/\",\"@type\":\"Person\",\"@name\":\"Microsoft Threat Intelligence\"}],\"headline\":\"Flax Typhoon using legitimate software to quietly access Taiwanese organizations\",\"datePublished\":\"2023-08-24T16:30:00+00:00\",\"dateModified\":\"2025-07-03T12:00:53+00:00\",\"mainEntityOfPage\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\"},\"wordCount\":2945,\"publisher\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage\"},\"thumbnailUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg\",\"keywords\":[\"Living off the land\",\"Typhoon\"],\"inLanguage\":\"en-US\"},{\"@type\":\"WebPage\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\",\"name\":\"Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog\",\"isPartOf\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website\"},\"primaryImageOfPage\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage\"},\"thumbnailUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg\",\"datePublished\":\"2023-08-24T16:30:00+00:00\",\"dateModified\":\"2025-07-03T12:00:53+00:00\",\"description\":\"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.\",\"breadcrumb\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#breadcrumb\"},\"inLanguage\":\"en-US\",\"potentialAction\":[{\"@type\":\"ReadAction\",\"target\":[\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/\"]}]},{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg\",\"contentUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg\",\"width\":1200,\"height\":800},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#breadcrumb\",\"itemListElement\":[{\"@type\":\"ListItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\"},{\"@type\":\"ListItem\",\"position\":2,\"name\":\"Flax Typhoon using legitimate software to quietly access Taiwanese organizations\"}]},{\"@type\":\"WebSite\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\",\"name\":\"Microsoft Security Blog\",\"description\":\"Expert coverage of cybersecurity topics\",\"publisher\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\"},\"potentialAction\":[{\"@type\":\"SearchAction\",\"target\":{\"@type\":\"EntryPoint\",\"urlTemplate\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?s={search_term_string}\"},\"query-input\":{\"@type\":\"PropertyValueSpecification\",\"valueRequired\":true,\"valueName\":\"search_term_string\"}}],\"inLanguage\":\"en-US\"},{\"@type\":\"Organization\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization\",\"name\":\"Microsoft Security Blog\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/\",\"logo\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/\",\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png\",\"contentUrl\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png\",\"width\":512,\"height\":512,\"caption\":\"Microsoft Security Blog\"},\"image\":{\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/\"}},{\"@type\":\"Person\",\"@id\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/person\/fa785acae88a9b0cfe278a692ce196f5\",\"name\":\"Microsoft Security Threat Intelligence\",\"image\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g430eaf64ccad6ceda364c6ea504461c5\",\"url\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g\",\"contentUrl\":\"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g\",\"caption\":\"Microsoft Security Threat Intelligence\"},\"url\":\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/v-katiemc\/\"}]}<\/script>\n<!-- \/ Yoast SEO plugin. -->","yoast_head_json":{"title":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog","description":"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.","robots":{"index":"index","follow":"follow","max-snippet":"max-snippet:-1","max-image-preview":"max-image-preview:large","max-video-preview":"max-video-preview:-1"},"canonical":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/","og_locale":"en_US","og_type":"article","og_title":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog","og_description":"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.","og_url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/","og_site_name":"Microsoft Security Blog","article_published_time":"2023-08-24T16:30:00+00:00","article_modified_time":"2025-07-03T12:00:53+00:00","og_image":[{"width":4096,"height":2304,"url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Twitter-card-Flax-Typhoon-1.png","type":"image\/png"}],"author":"Microsoft Threat Intelligence","twitter_card":"summary_large_image","twitter_image":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Twitter-card-Flax-Typhoon-1.png","twitter_misc":{"Written by":"Microsoft Threat Intelligence","Est. reading time":"14 minutes"},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#article","isPartOf":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/"},"author":[{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/microsoft-security-threat-intelligence\/","@type":"Person","@name":"Microsoft Threat Intelligence"}],"headline":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations","datePublished":"2023-08-24T16:30:00+00:00","dateModified":"2025-07-03T12:00:53+00:00","mainEntityOfPage":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/"},"wordCount":2945,"publisher":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg","keywords":["Living off the land","Typhoon"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/","name":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations | Microsoft Security Blog","isPartOf":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website"},"primaryImageOfPage":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg","datePublished":"2023-08-24T16:30:00+00:00","dateModified":"2025-07-03T12:00:53+00:00","description":"Microsoft has identified the nation-state activity group Flax Typhoon is targeting organizations in Taiwan, likely to perform espionage.","breadcrumb":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#primaryimage","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2023\/08\/Flax-Typhoon-featured-image.jpg","width":1200,"height":800},{"@type":"BreadcrumbList","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/08\/24\/flax-typhoon-using-legitimate-software-to-quietly-access-taiwanese-organizations\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/"},{"@type":"ListItem","position":2,"name":"Flax Typhoon using legitimate software to quietly access Taiwanese organizations"}]},{"@type":"WebSite","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#website","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/","name":"Microsoft Security Blog","description":"Expert coverage of cybersecurity topics","publisher":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?s={search_term_string}"},"query-input":{"@type":"PropertyValueSpecification","valueRequired":true,"valueName":"search_term_string"}}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#organization","name":"Microsoft Security Blog","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2018\/08\/cropped-cropped-microsoft_logo_element.png","width":512,"height":512,"caption":"Microsoft Security Blog"},"image":{"@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/logo\/image\/"}},{"@type":"Person","@id":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/#\/schema\/person\/fa785acae88a9b0cfe278a692ce196f5","name":"Microsoft Security Threat Intelligence","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g430eaf64ccad6ceda364c6ea504461c5","url":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g","contentUrl":"https:\/\/secure.gravatar.com\/avatar\/6da614d6e26efc7ec75a4b5a98d63c541af444fa76a10c41a66be5b3de0a63aa?s=96&d=microsoft&r=g","caption":"Microsoft Security Threat Intelligence"},"url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/author\/v-katiemc\/"}]}},"bloginabox_animated_featured_image":null,"bloginabox_display_generated_audio":false,"distributor_meta":false,"distributor_terms":false,"distributor_media":false,"distributor_original_site_name":"Microsoft Security Blog","distributor_original_site_url":"https:\/\/www.microsoft.com\/en-us\/security\/blog","push-errors":false,"_links":{"self":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/131410","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/users\/153"}],"replies":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/comments?post=131410"}],"version-history":[{"count":2,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/131410\/revisions"}],"predecessor-version":[{"id":141070,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/posts\/131410\/revisions\/141070"}],"wp:featuredmedia":[{"embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/media\/131423"}],"wp:attachment":[{"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/media?parent=131410"}],"wp:term":[{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/post_tag?post=131410"},{"taxonomy":"threat-intelligence","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/threat-intelligence?post=131410"},{"taxonomy":"content-type","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/content-type?post=131410"},{"taxonomy":"job-role","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/job-role?post=131410"},{"taxonomy":"product","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/product?post=131410"},{"taxonomy":"topic","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/topic?post=131410"},{"taxonomy":"author","embeddable":true,"href":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-json\/wp\/v2\/coauthors?post=131410"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}