開発ツール対応 OS 一覧

最終更新日: 2015/4/21

ご注意: この一覧は全て開発ツール自体の動作に関する情報であり、以下の開発ツールを使用してお客様が開発されたアプリケーションの対応に関するものではありません。これらの開発ツールを使用して開発されたアプリケーションは、全てお客様の責任において必要な環境下でテストしていただく必要があります。お客様の開発されたアプリケーションの動作に関して、弊社では一切の保証はいたしませんので、あらかじめご了承ください。

 凡例
 : 対応しています
× : 対応していません
Windows XPWindows Server 2003Windows VistaWindows Server 2008Windows Server 2008 R2Windows 7Windows Server 2012Windows Server 2012 R2Windows 8Windows 8.1Windows 10
Visual C++ 6.0
(*1)

(*3)
×××××××××
Visual Basic 6.0
(*1)

(*3)

(*7)

(*7)
×××××××
Visual InterDev 6.0
(*1)
××××××××××
Visual SourceSafe 6.0c (*2)
(*1)
×××××××××
Visual SourceSafe 6.0d
(*1)
×××××××××
Visual SourceSafe 2005
(*4)

(*10)

(*10)

(*10)

(*10)
×××××
Visual Studio .NET 2002×××××××××
Visual Studio .NET 2003×××××××××
Visual Studio 2005
(*5)

(*6)

(*8)

(*8)

(*8)

(*8)
×××××
Visual Studio 2008
(*5)

(*9)

(*11)
(*12)

(*11)
×××××
Visual Studio 2010
(*13)

(*14)

(*15)

(*16)

(*17)

(*17)

(*17)

(*17)

(*17)
Visual Studio 2012××××
Visual Studio 2013××××
Visual Studio 2015××××
*1:リモート デスクトップおよびユーザーの簡易切り替えは除きます。
*2:Visual SourceSafe 6.0c 以前のバージョンをお使いのお客様は適切なサービス パックの適用が必要です。詳しくは Visual SourceSafe データベース運用ガイドをご覧ください。
*3:Visual Studio 6.0 Service Pack 6 の適用が必要です。
» Visual Studio 6.0 Service Pack 6 のダウンロード (PDF、326 KB)
*4:Windows XP Professional Service Pack 2 以上
*5:Windows XP Home Edition Service Pack 2 以上、Windows XP Professional Service Pack 2 以上、Windows XP Media Center Edition 2002 Service Pack 2 以上、Windows XP Media Center Edition 2004 Service Pack 2 以上、Windows XP Media Center Edition 2005 Service Pack 2 以上、および Windows XP Tablet PC Edition Service Pack 2 以上
*6:Windows Server 2003 Standard Edition SP1 以上、Windows Server 2003 Enterprise Edition SP1 以上、Windows Server 2003 Datacenter Edition SP1 以上、および Windows Server 2003 Web Edition SP1 以上
※ Visual Studio 2005 は、Intel Itanium (IA64) を搭載しているコンピューターにはインストールできません。
*7:Windows Vista および Windows Server 2008 以降の環境における Visual Basic 6.0 のサポートについては、「Windows Vista、Windows Server 2008、Windows 7、および Windows 8 に対する Visual Basic 6.0 のサポートに関する声明」をご覧ください。
*8:Visual Studio 2005 を Windows Vista もしくは Windows Server 2008 環境で動作させるためには、Visual Studio 2005 Service Pack 1 および Visual Studio 2005 Service Pack 1 Update for Windows Vista の適用が必要です。詳細については、「Windows Vista で動作する Visual Studio」をご覧ください。
※ Visual Studio 2005 Team Foundation Server は Windows Server 2008 上での動作はサポートされません。
*9:Windows Server 2003 Service Pack 1 以上、もしくは Windows Server 2003 R2 以上
※ Visual Studio 2008 は、Intel Itanium (IA64) を搭載しているコンピューターにはインストールできません。
*10:Visual SourceSafe 2005 については、HTTP 経由のシナリオがサポートされません。
*11:Visual Studio 2008 Service Pack 1 の適用が必要です。
*12:Team Foundation Server (TFS) のアプリケーション層は 64-bit OS に対応しておりません。TFS を 1 台のコンピューターで構成する場合、Windows Server 2008 R2 にはインストールすることはできません。TFS を 2 台以上のコンピューターで構成する場合、データベース層のみ Windows Server 2008 R2 にインストールすることができます。アプリケーション層は Windows Server 2008 R2 にはインストールできません。詳しくはインストール ガイドをご覧ください。
*13:Windows XP Service Pack 3 以上
*14:Windows Server 2003 Service Pack 2 以上、もしくは Windows Server 2003 R2 以上
※ Visual Studio 2010 は、Intel Itanium (IA64) を搭載しているコンピューターにはインストールできません。
*15:Windows Vista Service Pack 2 以上
*16:Windows Server 2008 Service Pack 2 以上
*17:Visual Studio のパフォーマンス ツールは、Windows 8 を実行しているコンピューターではサポートされていません。(KB2748309)

その他のご注意

  • 本ページに記載している多くの旧バージョンの製品については、パッケージでの販売を終了しております。しかし、MSDN サブスクリプションでは最新の Visual Studio ファミリをはじめ、一部の旧バージョンも提供しております。
  • ここに記述されている情報は全て日本語版に関するものです。
  • マイクロソフトでは、ユーザーが開発したアプリケーションが対応 OS で動作するかどうかに関しては一切保証しません。ユーザー自身の責任で OS 毎にテストしていただく必要があります。
  • この表は各 OS 上の開発ツールの動作状況を示しています。組み合わせによっては、各 OS 特有の機能を使用したアプリケーションを構築できない場合があります。
  • 必ず最新版サービス パックを適用してください。
  • InstallShield for Microsoft Visual C++ 6.0、Seagate Crystal Reports for Visual Basic などのマイクロソフト製以外の製品の動作確認状況は上記の表に含まれておりません。これらの製品のテクニカル サポートにつきましては、"お使いになる前に"、または「[VB] Crystal Reports for Visual Basic のサポートについて」をご参照ください。
  • マイクロソフトによるサポート サービスは、その製品がサポート ライフサイクル期間に提供されます。
    » 開発ツールのサポート ライフサイクル
  • 以前のバージョンの対応状況はこちらをご覧ください。

▲ Top of Page